SV06 Plus Midprint lockup

Good day, all!
Here is a puzzle for everyone!
My 6+ has been doing an outstanding job - I set it up two weeks ago got it leveled and started printing. I have printed several different Calibration prints that have come out incredibly good.

I have printed the 3X5 Cards that can store SD Cards and 3x5 card with notes on the contents.
I have printed several different size drawers? for the rolling hex storage - medium and Large.

My 3x5 prints took 9 hours to print multiples. The Kickstarter calibration - the biggest calibration tool printed successfully as well, I dont recall the print time.

We had a storm roll through while the printer was off. Lost power 4 or 5 times over the course of about 10 minutes then power stayed off for about 4 hours, again the printer was off but still connected to 110V. Since that time I can not get a succesful print.

Here are the details -
1st print Hex Roller XL Storage Core and Cap estimated by the printer to take 9 or 10 hours.
Printed 14% just fine then the print head froze. Temp maintained on Nozzle and Bed - Fan continued to run. No motion from the printhead. Used the touchscreen to stop the print the screen responded are you sure. Clicked yes no effect. tried multiple other screens still no effect the screens did respond to touch.
Finally powered off.

2nd print same Gcode different SDHC Card same end results except it only printed 7% before lockup? Not even sure what to call it.

At this point I proved it wasnt a card read issue so thought maybe it was related to altitude of the Print Head excuse me Z axis issue…

3rd print resliced the source and only attempted to print the core no cap. Made it to 3% before freeze up.

4th print - 2 small calibration cubes freshly sliced. That print made it to 4%.

I have ruled out flow issue, heating issues, print head physically getting stuck on the print.

To further troubleshoot I attempted to reflash the firmware which was at Version 1.1.4 - not able to reflash with current Bin file dated 24th.

I am planning to convert this printer to the Klipper setup using the Bique Pad 7 and have prepped the SDHC Card with the Klipper firmware but have not attempted that yet… should I just to get it to reflash then flash it back to 1.1.4???

Any other troubleshooting suggestions?? Or ways to remediate??

Lost and Frustrated!!!

Sorry to hear of your problems. I highly doubt that flashing another firmware will solve your issue.
For me it sounds that one of the modules of the motherboard was damaged by the power outages.
Replace the motherboard would be my recommendation.
Good Luck!

Corrupted firmware or f’ed motherboard. I’d try reflashing firmware, Or flashing klipper. If to no avail. Try sovol support

Sorry for your experience!

It can be frustrating, but when you “make it out the other end”, I suspect it will be worth it. But still frustrating.

I would now start with a different power source. Maybe an outlet on a different circuit. I doubt this is it, but it is an easy test. I believe your issues are related to a failing/failed power supply. If you can test the supply under a similar load that the printer subjects it to, I would monitor the power supply’s output.

Hang in there!

I had a problem with the power switch on my unit. When I looked at it it looked like it had a power surge and cooked the connection I could not turn unit off and had to pull the cord. The switch has 2 sides you could try moving the connection to the other side to see if this helps.

Are you able to watch the print with octoprint or pronterface to see if anything shows in the logs as to what the issue is? Right now it’s all speculation and I doubt the storm did anything. Also, start with the simple things you can easily check. Make sure all of your plugs are tight and not loose. I had my X come out on meat at one point. Maybe sure none of the wires on the print head are broken or loose. I wouldn’t go Klipper until you have diagnosed this. As slow as Sovol support is, you will want to open a case with them as well.

Thanks all - I had avoided opening a Sovol support case simply because even though I am 10 years from retirement I didnt want to do that awaiting a reply Grin…

So a couple reminders - the print failed and then I would shut off the printer restart then launch into the next print - the print goes perfectly no issues on the print except the print head stops - seriously the fan is still running the screen is reporting the temp is still where it should be (confirmed that by touch as well as laser temp probe)… the filament feed stops along with the X,Y,Z motors. So at this point it is not any kind of physical failure like filament out (the feed tracker whatever it is called is still displaying green) printhead hopping or anything like that the print what little is done is perfect. I literally turn the printer off raise the z a bit to get the failed print out of the way and do the next print no messing with filament feed or anything like changes…

No setup for octo print or pronterface yet that is where I was headed when I finally pulled the trigger on setting up klipper.

I thought about the firmware changing to Klipper just to force the system to reload the firmware because it evidently cant with it already at the 1.1.4 level…

Definitely not going the klipper route without resolving this issue that leads to madness (maybe already there!!)

I will look into the power supply but I would think that doing one print and with the stuff still active it wouldnt be the power supply… hmmm something just occurred to me, I will check if the steppers are run off different leads on the PS than runs the screen etc, if that is the case then it makes sense that part of the power supply is flaky and that part doesn’t fail until after a certain amount of time or the PS heating up…

Has anyone gone the Replacement route with the Meanwell from TH3D??

I have not tried a factory reset! That is an easy test…

To all thanks very much for your suggestions and insights! I will report back my progress!!!

1 Like

I would start with the power supply. The factory unit is notoriously bad and it sounds like yours has been affected by the power outages and voltage spikes on the mains that occurred during them.

If you’re in the USA, get it from TH3D. International, I’d look locally - the Meanwell LRS-350-24 is what you need. I’m in Australia and was going to source from TH3D but his shipping company’s charges are ridiculously expensive, like more than the cost of the part itself. I managed to find one locally after some searching. Haven’t ordered it yet, will get around to it later today. You will need the shroud that goes around the bottom to cover the connections and mount it to the printer. Tim has a pre-printed version and a download/print-it-yourself STL.

Good luck!


sounds like the motherboard could be damaged now, the power supply they give us is very cheap and if the ohm resistance on the power supply is bad as my was when i checked it replace the power supply for a meanwell 350 power supply which is a very good power supply.

1 Like

Could you explain to me why you don’t use a 500W Meanwell as the stock power supply ?

1 Like

You should probably ask Sovol that question, but from what I can see, the next power supply in the Meanwell single-rail 24V range is the LRS-450-24 (i.e. 450 Watts), which is a good deal larger than the LRS-350-24. It doesn’t look like they have a 500 in that range, at least available in Australia.

The LRS-350-24 is roughly the same size as the factory Sovol unit, so it is the one that most people replace it with. Even though the stock one is rated for 400, Tim @ TH3D did some tests and found that it never uses more than 350 even when under load. Have a look on his website and/or YT.

The 450 would work but you’d have to run it externally I think, from the look of it, it would be too big to fit to the 06+ gantry like the stock one does, without interfering with the bed or right hand side of the x-axis.

Sovol are obviously building to a price so they source their own cheap brand rather than a more expensive Meanwell as stock.



To be honest anything above 350watts is way overkill especially considering the bed is so thin and not a very high watt heater to boot.

Alrighty i gotta ask ar you sure electricity is stable now?

Because this happens to me when i switch power source(generators) real quick by switch in engineroom on ship.

Exactly as you describe it freezes movement.

Th sv06 plus is surprisingly sensitive to the power being correct.
I now have a ups too avoid quick switch and just lower my switching so it can really switch to the ups and that seems to work.

I believe other countrys sometimes get seperate surg protectors maybe that could work.

But first try a different circuit in your home maybe there is a lot of power being drawn already on that circuit that might cause small power dips not huge but small.

Maybe someone with a more electrical background cab explain better.

Thanks lucked out the local Microcenter had one of the Meanwell 350’s left! Got it picked up will swap it tomorrow night and see where that leaves me…

Just surge protection or full ups?
There are different types online it doesnt have a switching time.
Line interactive it switches quickly when power drops this does nkt work if your preheating the bed and nozzle if you dont have 400 watt ups mine is 360 it conks out at that moment during printing it works like a charm.

I really hope its not a damaged board because that would suck.

Interesting. Wonder whether the heat up phase for the bed will be quicker than. This takes awful lot of time.

1 Like

Nope it just uses more amps while heating up from cold when near teml amperages drop.
At least thats how j understand that pid heating does it

Thanks I really hadn’t thought about a UPS … great idea!

I am not an electronician but friend of mine who is a good specialist told me that the power of 350W does’nt correspond to the peak current required to power the BED at the risk of doubling the heating time.
He proposes me to investigate the issue in order to regulate the voltage to reduce noise with electronic components.
He thinks a LM741 comparator and a Mosfet will do the trick, driven by a CTN, for him it should work on a regulation request.

Fir clarification ups wattage is just the max you can draw out of it but 400 watt ups theoretically cannpower 400 watt device for like 2.5 minute but you can probably extend that time by wiring a external battery.
In mine is a 12 volt maintenance free lead battery.

About the specs of the hotbed i have no clue but if your right the current draw is limiyed somewhere otherwise it would burn the psu if i understand it correctly.
But if its just peak current it probably doesnt really matter for operation maybe length of life.

A ptc heater of 100 watt has a peak of 1000watt but that is like a few milliseconds.

But would be kinda cool to make the bed heat faster cause it feels like a eternity haha