SV06 - Auto Bed Levelling Incosistent

Well, until Sovol come up with a fix I’ve MacGyver’d mine and it seems to be working much better. I printed off a single layer 0.2mm high test ring about 150mm in diameter, then peeled it off and measured it. On the left it measured 0.2mm thick, on the right it is 0.42mm, so I unscrewed the heat plate and added a 0.2mm shim washer on top of each of the right hand support pillars and removed the centre pillar. If you try this don’t do a bed level after you’ve added the shims as you will be back to square one.

1 Like

so what ive done to fix the mesh to the best i can without a official firmware update from SOVOL is as follows. im not sure which of these did it, but its not to hard to combine all of them.

First, go around to each individual screw and check for tightness. i found several that definitely could have been tightened more from the factory, especially the top 4 screws on the Gantry.


  1. in CURA, add the line M240 S1 after the G28 command code in the starting Gcode (prefrences-> Configure sovol-> printers-> Machine Settings) this makes sure the mesh bed leveling is turned back on after the G28 Code, which in Marlin Firmware disables it?

  2. run auto z axis level. when its about to do the death rattle up top aligning itself, get ready, and apply a solid amount of pressure upwards into the stops when it reaches it with your thumbs on each side breifly. my thought here was to help it get as level as possible, since Modbot had mentioned it was why he did the soup can method in the first place.

  3. Auto Home. STORE SETTTING

  4. Probe your Z axis offset and adjust accordingly. STORE SETTING

  5. Run the bed leveling. STORE SETTING

  6. Change the Fade Height from 10 to 15. my thought here was to give the mesh logic more time to compensate for bed level changes.

  7. in CURA, load up your favorite bed level print of your choice and set the height of the model to .3 if its below.

  8. set your initial layer height to .3 and slow the first layer down a bit. on my testing i set it to 20 mm/s

  9. Load it up and print. watch the squares fill in, and as it goes, on printer click the wheel and go to Tune-> probe Z offset. gradually bring it down until you get a happy medium between the left and right. dont forget to STORE SETTINGS after each adjustment. i backed completely out of the config menu for good measure as well but might not be needed.

All this being said. Sovol needs to push a firmware fix for this ASAP because otherwise this is a fantastic printer out of the box.

1 Like

@spitblood08 thanks for the extremely detailed reply, I’ll give that a go at the weekend. I have seen references to the M240 S1, I am no expert on this but surely the bed leveling is already turned on because the two z motors/z axis lead screws can be seen turning when the print-head is moving sideways across the bed. If the machine wasn’t compensating then these would be stationary other than at z-hops or layer change? I have thought about making a pair of spacers a bit more accurate than bean cans and manually setting the z height each time I power the machine on, if this is what it takes the so be it. Thanks.

Just chiming in that I’m also experiencing this issue. It’s not a problem for small prints, but large prints are impossible. I also can’t find any firmware available anywhere to try to amend the problem.

Same problem here, nothing will really work, try the steps on Tuesday,ordered a other pro plate, if it doesn’t work I’ll have fun with Sovol support to get the machine back to sender

You can find the firmware here:

Thanks for the help @spitblood08, I spent a couple of hours making sure all the factory fixings were tight, I updated the firmware to Sovol’s latest release and then followed though your bed leveling guide and added the extra g-code and the printer is definitely better. I don’t do very many prints which need a thin extrusion, so I also switched to a 0.6mm nozzle which has improved things further. Cheers.



Ich habe mit meinem SV06 das selbe Problem. Nach dem Leveln ist die linke Seite immer höher als die rechte Seite. Obwohl ich vorher auch die Z Achsen ausgerichtet habe.
Behelfe mich aktuell auch mit 0.2mm Unterlegscheiben.
Wenn ich dann aber neu level, habe ich exakt das selbe Druckbild im Bedleveltest wie ohne Scheiben. Denke auch das es ein Problem der Firmware ist.
Weiß jemand ob es diesbezüglich ein Firmware-Update geben soll?

Try in Advanced Settings >TMC Drivers> Sensorles Homing value to 68 or 69 for both x and y. Or until it stops grinding.

1 Like

On my printer the bed mesh compensation is calculated and working but y axis is turning on the wrong direction which seems to be doubling the error on the first layer.

I’m having the same issue as what seemingly hundreds of people are having. One side of bed is clearly significantly higher than the other because the X gantry isn’t aligned properly. I’ve tried every method I’ve been able to find. Sovol. Please do something!!!

1 Like

First check whether the fixing screws (refer to the picture, 4 left and right) of the top beam of the gantry frame are tightened? Is there a slant on the mount? Try using a wrench to tighten it up.

Check whether the fixing screws of the hot bed (refer to the picture) are tightened? Try using a wrench to tighten it up.

Refer to the tutorial to remove the heat bed, and measure whether the lengths of the 5 spacers (refer to the picture) under the heat bed are the same.
Disassembly hot bed tutorial: How to replace the soft magnetic film and hot bed | Sovol SV06 - YouTube

After checking the reinforcement, re-flash the firmware, and then try to run Auto Z-align and Leveling Bed, that is, re-leveling.

Firmware link: Firmware Download | Sovol3d

Flash firmware video tutorial: How to flash the firmware | Sovol SV06 - YouTube
Leveling Tutorial: How to level the bed | Sovol SV06 - YouTube

About Bearing Sound
The machine uses ball bearings. When moving, the small balls in the bearing (refer to the picture) and the optical shaft will directly roll and rub, and it is normal to make some noise.
Appropriate addition of lubricating oil can reduce the sound of contact friction and enable smooth sliding.

I think, the right parameter to read the mesh bed data is M420 S1 (not 249). I try this in cura and it works for me. The other problem i found out: the Z-sensor was not screwed tight, so any bed leveling was a kind of random. After correct it, any printout was way better than before. Dont forget to “home” before any leveling!

M420 S1 sollte das Problem in Cura beheben. Nach dem G28 eintragen!

I’ve fixed the problem with the lower right side in a similar way: 1. unscrew the plate, 2. Put 0,4mm metal spacers on top of the support pillars on the right side (2 pieces). 3. re-run z… and bed levelling.

It’s much better (no curling up when printing full plate prints), but not as it should be. Today I’ll try to add M420 S1 code and will see.

I’ve noticed that the whole printer is skewed to the left and the vertical pillars/axes are not perpendicular to the plate (maybe 88 degrees instead of 90).

BTW: the ‘Can soup’ method didn’t work for me.

Entering M420 S1 after G28 doesn’t change a thing for me. Still, the bed is lower on the right side.

Sorry, but this procedure doesn’t work.
Even M420 S1 method doesn’t work.

The problem is the mesh is probably incorrectly generated or it doesn’t compensate x gantry twist.
Please see debate here:

Currently, the only solution is to manually do the bed levelling with modified firmware.

Dear Sovol, please fix the firmware ASAP.