SV06 normal noise?

You need to change your sensorless homing setting. From this thread:

“Try in Advanced Settings >TMC Drivers> Sensorles Homing value to 68 or 69 for both x and y. Or until it stops grinding.”

I know your issue isn’t bed leveling like that linked thread, but your sensorless homing on the X axis needs tuning. It shouldn’t grind like that. It should basically just bump the side and then it’s done - no grinding at all. It’s just a firmware setting though you can adjust via the screen, so should be an easy tweak.