SV06 - Auto Bed Levelling Incosistent

Thanks for the help @spitblood08, I spent a couple of hours making sure all the factory fixings were tight, I updated the firmware to Sovol’s latest release and then followed though your bed leveling guide and added the extra g-code and the printer is definitely better. I don’t do very many prints which need a thin extrusion, so I also switched to a 0.6mm nozzle which has improved things further. Cheers.



Ich habe mit meinem SV06 das selbe Problem. Nach dem Leveln ist die linke Seite immer höher als die rechte Seite. Obwohl ich vorher auch die Z Achsen ausgerichtet habe.
Behelfe mich aktuell auch mit 0.2mm Unterlegscheiben.
Wenn ich dann aber neu level, habe ich exakt das selbe Druckbild im Bedleveltest wie ohne Scheiben. Denke auch das es ein Problem der Firmware ist.
Weiß jemand ob es diesbezüglich ein Firmware-Update geben soll?

Try in Advanced Settings >TMC Drivers> Sensorles Homing value to 68 or 69 for both x and y. Or until it stops grinding.

1 Like

On my printer the bed mesh compensation is calculated and working but y axis is turning on the wrong direction which seems to be doubling the error on the first layer.

I’m having the same issue as what seemingly hundreds of people are having. One side of bed is clearly significantly higher than the other because the X gantry isn’t aligned properly. I’ve tried every method I’ve been able to find. Sovol. Please do something!!!

1 Like

First check whether the fixing screws (refer to the picture, 4 left and right) of the top beam of the gantry frame are tightened? Is there a slant on the mount? Try using a wrench to tighten it up.

Check whether the fixing screws of the hot bed (refer to the picture) are tightened? Try using a wrench to tighten it up.

Refer to the tutorial to remove the heat bed, and measure whether the lengths of the 5 spacers (refer to the picture) under the heat bed are the same.
Disassembly hot bed tutorial: How to replace the soft magnetic film and hot bed | Sovol SV06 - YouTube

After checking the reinforcement, re-flash the firmware, and then try to run Auto Z-align and Leveling Bed, that is, re-leveling.

Firmware link: Firmware Download | Sovol3d

Flash firmware video tutorial: How to flash the firmware | Sovol SV06 - YouTube
Leveling Tutorial: How to level the bed | Sovol SV06 - YouTube

About Bearing Sound
The machine uses ball bearings. When moving, the small balls in the bearing (refer to the picture) and the optical shaft will directly roll and rub, and it is normal to make some noise.
Appropriate addition of lubricating oil can reduce the sound of contact friction and enable smooth sliding.

I think, the right parameter to read the mesh bed data is M420 S1 (not 249). I try this in cura and it works for me. The other problem i found out: the Z-sensor was not screwed tight, so any bed leveling was a kind of random. After correct it, any printout was way better than before. Dont forget to “home” before any leveling!

M420 S1 sollte das Problem in Cura beheben. Nach dem G28 eintragen!

I’ve fixed the problem with the lower right side in a similar way: 1. unscrew the plate, 2. Put 0,4mm metal spacers on top of the support pillars on the right side (2 pieces). 3. re-run z… and bed levelling.

It’s much better (no curling up when printing full plate prints), but not as it should be. Today I’ll try to add M420 S1 code and will see.

I’ve noticed that the whole printer is skewed to the left and the vertical pillars/axes are not perpendicular to the plate (maybe 88 degrees instead of 90).

BTW: the ‘Can soup’ method didn’t work for me.

Entering M420 S1 after G28 doesn’t change a thing for me. Still, the bed is lower on the right side.

Sorry, but this procedure doesn’t work.
Even M420 S1 method doesn’t work.

The problem is the mesh is probably incorrectly generated or it doesn’t compensate x gantry twist.
Please see debate here:

Currently, the only solution is to manually do the bed levelling with modified firmware.

Dear Sovol, please fix the firmware ASAP.

Somehow I can’t get any good print, I’ve tried a several methods of leveling and it seems to me that even with manual physical adjustment, the distance between the nozzle and bed is not homogeneous over the entire bed or is not balanced. I think the auto level doesn’t work at all even with newest FW which I upgraded to 1.1.5 few days back. I’d rather have a manual bed level and be sure that it works.