Z calibration buggy

I am not sure what I am doing wrong, but this is my flow (my nozzle is heated to 120c and bed is heated to 60c):

  1. I press auto align Z, and wait until it is done
  2. I take a piece of paper and hone the Z down until the paper is barely scratched by the nozzle
  3. I press save
  4. I insert the paper in-between the bed and nozzle again, but this time the gap is wide, so I have to adjust again
  5. I press save
  6. Now the paper can barely fit, so I have to move it a bit up again
  7. I press save
  8. If I am lucky, I can now press auto level bed, and wait otherwise I will need to keep adjusting the Z
  9. Once the auto bed leveling is complete I need to adjust Z again since the gap has become either too wide or too small
  10. I press save
  11. Gap is now either too wide or too small again, so I repeat the process until it is eventually consistent

I am starting to lose my mind. I have checked the nozzle, and there is no filament dripping or dried out which could add some extra mm.

Anyone else have experienced this issue? I am new to 3D printing, so this is my first machine. I am starting to regret I followed the hype a bit. People on YouTube makes this look so easy, but I have spent countless of hours trying to calibrate this machine, and every time I turn it on, I need to start on a fresh because the gap has changed when I press auto home.

Edit: I have tried to restore factory settings, and also tried to re flash the firmware. But neither helped.

Do steps 1, 2 & 3…then level the bed & click save…your done…(do not re-set the Z offset)
The nozzle will always be off the bed until you start your print.

Drove me insane as well. Turned out it was likely the power supply.

Does your screen sometimes glitch and display flat out physically impossible values like minus 400-something °C? Or thousands of hours of remaining print time? Are touch inputs sometimes ignored? Does the screen freeze during mesh leveling? Most likely the PSU.

Seems that the PSU has so much electrical noise that it starts to freak out the CPU or some other components like sensors or the data connection to the screen. Mine for sure freaked out our FM radios in the house while under load.

I swapped mine for a much more expensive brand one, and would you belive it! Everything works now (except the power switch started to melt and nearly caused a fire; close call. Might not be up for the task of 50+ A of inrush start current.). Heared the same for the stock PSU as well. You get what you pay for obv.

Hei, did you resolved the problems? If yes how? thanks!