SV07plus Moonraker connection problems

OK the tag I was forced to use is meaningless. If required to assign a tag, how about providing some that are not so limiting. Like “Klipper” “Moonraker” or even, ALL PRINTER MODELS instead of a random few?

Anyway, I have new SV07 Plus. Printed OK for about 10 days, but now I can’t stay connected via Moonraker. Connection very unreliable, drops, connects, drops connects.

Sep 23 15:06:58 mkspi python[1348]: [] - Websocket Closed: ID: 281472803442360 Close Code: None, Close Reason: None, Pong Time Elapsed: 36.44

Any ideas?

Do you tried to login over ssh and overlooked all services?
I had similar issues, but got it fixed with the correct ntp settings.

Do you have anything metal near the edge of the LCD control unit? The antenna for WiFi is in the upper right side of the controller unit (a bit of sticky attached to the inside of the upper half). If you have something metallic near it, that could be interfering or blocking your signal.

Looks like a poor network connection. Did you move the printer or wifi access point recently, or move something that may be interfering?

The antenna built in is pretty weak, but you can buy another one with a ufl connector - something like this should be compatible, though you’ll probably need to make a small hole in the case to thread the adapter wire

I have logged in over SSH. It took forever to locate the logs because they’re not where other Klipper installs have them (according to internet searches). Ours are in /home/mks/printer_data/logs

This is my first 3D printer, so I’m completely new to R-Pi, Klipper, Moonraker, etc… I do have some Linux background so I’m not totally lost. I have WinSCP but searches are so slow, I gave up hunting that way.

So where would I go to check or edit the NTP server?

That looks worth a try. This is a 2.4GHz on a mesh which gives me some trouble. 5GHz is perfect for some reason. It worked great until 2 days ago though and it has not been moved. Signals look good.

There is a wide-format HP plotter, also 2.4GHz with its control board just inches from the SV07+ screen. It had been in deep sleep and I think the problem may well have started when I recently woke it up.

The system here is based on armbian, which keeps its NTP config under /etc/ntp.conf. However, I’d recommend first doing sudo armbian-config and making sure the timezone setting is correct, since having the right time zone data can also affect connections.

If that doesn’t help, hopefully the stronger antenna will. Do your 2.4.GHz and 5GHz wifi networks have different SSID’s? If not, it might be trying to hop between them randomly, at which point your plotter on the 2.4GHz network might be causing interference.

sudo service --status-all
[ - ] alsa-utils
[ - ] chrony
[ - ]
[ + ] cpufrequtils
[ + ] cron
[ + ] dbus
[ + ] dhcpcd
[ + ] fake-hwclock
[ - ] haveged
[ - ] hostapd
[ - ]
[ - ]
[ + ] kmod
[ + ] loadcpufreq
[ - ] network-manager
[ - ] networking
[ - ] nfs-common
[ + ] nginx
[ - ] ntp
[ - ] openvpn
[ + ] procps
[ - ] resolvconf
[ ? ] rng-tools
[ + ] rpcbind
[ - ] rsync
[ + ] rsyslog
[ - ] screen-cleanup
[ - ] selinux-autorelabel
[ - ] smartmontools
[ + ] ssh
[ - ] sudo
[ + ] sysfsutils
[ + ] sysstat
[ + ] udev
[ + ] unattended-upgrades
[ + ] vnstat
[ - ] x11-common

I see that NTP isn’t running.

They do have different SSIDs. Caused too much trouble the other way. Turns out I had also put an Ecoflow close to the printer. We had a power outage recently while printing and I thought this would be a good use of it. It also has wireless and moving it seems to have cleared the problem. I don’t think it was the plotter.

I’ve ordered antenna kit and will install anyway. And, while we’re on the subject, how hard would it be to configure an RJ45 port? or a USB/RJ45 adapter? Printer is close to a GB switch.

Installing an RJ45 natively would be basically impossible - there’s nowhere on the board set up for it that I could see in my teardown post of the board, but a USB-to-RJ45 Ethernet adapter should work fine, assuming the chipset of the adapter works natively with armbian (most common brands like Intel should). It’s worth noting that if you’re running out of USB ports, the board should support any standard USB hub, as all the USB ports should be running in host mode. You may have to do some tinkering via SSH to get it to pull an IP, but all the software that relies on the network should be adapter agnostic once you have it set up

Spoke too soon. Still having problems.

But between your suggestion to improve Wifi with antenna and potential of using usb/eth adapter, I should be able to establish a reliable connection one way or the other. That’s something Linux is phenomenal at in my experience, supporting all sorts of hardware–essentially everything I’ve ever thrown at it including some crazy-old 90s era equipment.

And thanks for the hint about a USB hub. This board is already pretty generous with USB ports, but this is one area where more is better when you need it.

Sincere thanks!

Don’t use WinSCP, I know gui is always nice, but please use a native ssh session.
Like Putty, Windows Terminal or a Terminal under Linux/MacOS.

About ntp:
try armbian-config (as root) and set the time and zone through the utility.

There was also a discussion about chrony in the armbian forum:

thanks sovol sendin me out a new printer they tested the old one was a firmware issue i would not beable to fix it myself

And this helps in which way? @Panda2aa