SV06 connected to octoprint shows firmware issues

Your printer’s firmware supports host action commands, but then are disabled. The firmware will not inform OctoPrint about job pauses & cancellations, filament runouts, and similar firmware-side events. Fi fou want this functionality, you need to change you firmware’s configuration.

How do I change the firmware’s configuration?

Thanks
Jim

Hi,

I see the same and would like to know the answer to this question.

Thanks!

I think I have found the solution.

I updated the firmware to SV06-v192A-1028-1.3.bin:

Mine was on 1.9.0_A
Now the error in Octoprint doesnt seem to appear anymore:

image

Its pretty easy to install (even there are no instructions I could find).
Download the bin to a micro SD card.
Turn the printer off
Insert the card
Turn the printer on
Let it boot, it takes about 20 seconds and then it starts.

Let me know if this solved it for you.

1 Like

sovol3delger
Is there a way to see what the current firmware version is?
Thanks for you help
Jim

1 Like

@jamby yes, its under the About Printer > Printer Info screen:

1 Like

Im the guy that has been using computers since the 80´s.
WHY do the firmware links show for a .bin file ???
What are the ods that every download have any korrupt data ??

Can somebody that has a working bin file zipit ore 7zip and send it to me…
My email is shortnder@hotmail.com

I now have a 20 pound paperweight.

Have a good weekend.

Be sure to test things like runout and pause etc. On the SV01 Pro you can compile a new firmware with host action commands on but it does just remove the error in octoprint. This because Soval is running a heavy modified marlin version, where they have written many of the subroutines themself, and those do not support remote control.

Hondy

Does the new firmware allow uploading gcode files into the sovol from octoprint?

Thanks
Jim

I have a SV01 Pro, and never tried that, and atm I cant try it, its geting a new screen so I can try and run a vanila version of marlin on it. It’s in a couple of parts on my table atm :slight_smile:

Yes, you can load onto the pi or the SD card.

1 Like

Well this is turning into a mess. I have tried to load the firmware into my SV06, placed the SV06-v192A-1028-1.3.bin file on a new SD card and inserted the SD into the printer with the power off. Then powered the printer up by the main power supply but there was no noticeable difference on boot. The
screen came up and then displayed “SD INIT FAIL”. This is the same message I get when ever the the SD card is in the slot at power up.
I read somewhere, probably another printer brand, to rename the .bin file to “firmware.bin”. Tried that but same thing.
Anyone have a fix?
Thanks
Jim

I hope that the firmware provided by Sovol also works. Then Sovol has to provide the latest stable one.

Even building the firmware from the sources can only work if Sovol provides a working one.
Then you can add flashing LEDs later, when you are funny …

The original Marlin doesn’t have the SV06, only the SV01.
So only Sovol-Marlin source code will be available for SV06.

Unless someone is a programmer and fights through 100,000 lines of code to write it back to the original Marlin. I’ve seen small differences but can’t figure it out

What is the size of the card you used?
Did you try the card that came with the printer?

I flashed mine with no issue whatsoever when using the original SD card. Maybe the one you are using is too big?

Jenss / sovol3delger

Ok the power has been restored after 25 hrs so I can get on line…
Big problem is the ft/sd cards I am using are to BIG. So ordered some 8g cards. Now wait.

The card that came with the printer is a story. I printed Benchy and all went well but after loading a couple of other files and printing them it suddenly stopped working. Anytime I tried it showed “SD INIT FAIL” and when checked in linux with fdisk -l it reported no partition table. I hadn’t checked that before but I do remember seeing 3 files listed, manual, benchy, and the bin file. So it got chucked…

check out this link and the instructions about how to flash firmware.
SV06 Mainboard brick after updating Sovol Firmware - #5 by Melthor
about half way down theres and answer from Sovol with a link to a YouTube Video…

Thanks Guys
Jim

Yeh, personally I dont trust these unbranded sd cards. However in my case, I only used it to flash the machine and it seemed ok.

Normally I would just use an 8GB sandisk or something that has a similar reputation.

Let us know how you get on once you have a decent disk…

Regards