Sovol SV04 Hot Bed Thermal Runaway Error

Backstory & Introduction:
Hello all. I bought my Sovol SV04 in June 2, 2023 off of Amazon, and for the most part it has been working perfectly. I haven’t had a lot of time to fine adjust the second extruder, but I do look forward to that. I’ve done little additions here and now, adding cable guards and such. Otherwise it is stock. I connect it to my Raspberry Pi 3B, which I keep updated on a regular basis.

Issue:
For the last month or so, I’ve had the issue of a Bed Thermal runaway. I’m not sure what is causing it, or what I can do to fix it. After reading some articles, some people say it could be the board, the thermistor, or a goblin somewhere else. I’m really scared of opening up the case, but if that’s what I need to do then I can I guess. The weird part is that it is happening at a random time, and has no collation that I am able to understand. I’ve run a print for a benchy, but a larger print will show the error. Sometimes smaller prints show the error as well, so I’m really just not sure on what to do. Hopefully y’all will have some ideas. Thank you.

1 Like

Before opening your SV04 you may want to run heatbed PID-tuning. The process is described here.

If that doesn’t help opening the SV04 case is not that big thing: Disconnect the power cord first, then turn SV04 sideways carefully iot not to damage the gantry & keep the highest extruder from moving & crashing into the other extruder. Use a Philips screw driver to remove the 8 bottom screws, remove the bottom plate. The relevant heatbed cables for examination are located in the bottom left corner of the motherboard. Documention is available on page 29 of the SV04 user manual.

Good luck
Björn

1 Like

Hey! Thanks for your quick reply. I’ll see what I can do tomorrow. Do you possibly have a link to that manual? I’ll keep you updated. :slightly_smiling_face:

Really sorry. I should have read your message twice. I now see that you included a link in “Here.” I will check that out right now! Thanks!

Hello again! I’ve had some time to work on my 3D printer. I was able to run the test for the Hot End, and it was successful. However the Heated Bed Sent an error shortly after sending the “M303 E-1 S60 C8” command. Here is a picture of the console and the error on screen:
image

Not sure what exactly this means. Any help would be greatly appreciated. My guess is that something is wrong with either the bed connections, or the board itself. I’m really worried if its the board, cause I am not extremely technical when it comes to this kind of stuff. Figuring code for setting up a new board worries me. Here is the full log just incase I forget to add something.
Full Log.txt (70.8 KB)

Moving onto your second suggestion of just looking at the board/connections and referring to the manual of page 29.

I opened up the bottom plate, which was just like you said. 8 Small screws, not hard at all. I took some pictures just to make sure I don’t mess up anything important. Or at least I document it. I managed to find some water on the board where the Bed terminal and board power terminals are. They didn’t look to have any signs of burn marks, or arcing, or anything out of the ordinary otherwise. It must just be humidity I suppose? Not really sure how that is there when my house is air conditioned around 66 degrees at night (I sleep freezing, don’t judge) and 72 degrees during the day. I also don’t have food or drinks of any sort in that room.

Here are some photos of what everything looks like and what I was able to find.
image





If you have any suggestions @Bjoern then let me know. Not really sure what to do next, or what to do to prevent moisture from getting anywhere near that board. I’d really like to solve this issue, and thank you for all your help thus far.

1 Like

The protocol file indicates that your bed thermistor is working accurate as it shows the same temperature as both extruders. However, nothing happens when the heatbed is powered on which points to an electrical problem of the heatbed.

In case you or a trusted person can handle a multimeter this is what you can try:

  1. Unscrew the heatbed cables on the motherboard & measure the resistance of the heatbed. A working heatbed (assuming the 220 W / 24V type) should show roughly 2.6 Ohms resistance. If that is the case: Check if the resistance changes when wiggling on the connector cable near the heatbed. If that is the case: You’ll need to re-solder the cables at the bed solder connectors. Here is an example for the SV06.
  2. If there is no connection at all (infinite resistance): Check the solder connectors on the bed.
  3. If the bed solder points are OK: Measure bed resistance at the solder points between + and - connectors. If there is no connection: You’ll need a spare heatbed. If the resistance is close to 2.6 Ohms: Measure bed power cables between hotend solder point and motherboard cable end. In case of no connection: You’ll need to replace the cables between motherboard and heatbed.

Good luck
Björn

Ok. So I tried to do what you had mentioned in step 1. I believe it reached 2.6 ohms without any issues. (I’ll include a picture later when friends get home so I can have more hands) I wasn’t really able to check while wiggling the cable, but I will also try that to see if there’s any change and provide more information regarding the next steps.

My one question is that my Hot Bed was working before this, could this really be the culprit of an error occurring randomly? I just simply got the error message every once and a while as mentioned above, and the heated bed functioned just fine when printing. (However it would stop the print and waste filament) Or could the wires being broken some place cause a surge leading to the error message?

Please let me know @Bjoern, and thank you so very much for all the assistance! :slight_smile:

The error message is continuously generated if the difference between current temperature and target temperature is 30°C or more in a predefined time interval.

That occurring & disappearing error seems very likely an electrical connection problem depending on mechanical tension on the cable when moving the bed and/or bed temperature. Re-soldering the wires at the heatbed connectors should eliminate this error source.
An other possible error source could be the power supply, but this seems unlikely because even a weak power supply should have been able to heat up the bed at least a little bit. Measuring the 24V at the power supply when turning on & off the heatbed temperature would help to be sure about that.
An other thing you could try is to measure the voltage at the heat bed connectors on the motherboard when turning on & off the heatbed temperature. If there is no difference this would indicate to a defective power MOSFET on the motherboard - the component that controls the heatbed.

Good luck
Björn

Goodnight,
In this case, it would be possible to place a separate MOSFET module to heat the bed, right?
If possible, how would this connection be made?

AFAIK there is no documentation about a SV04 with separate power MOSFET switch available. Theoretically connecting drain, gate + source like the onboard MOSFET with drain + source cables dimensioned for 10A should work after removing/disconnecting the onboard MOSFET. Looking how this has been solved for Creality 3D printers & keeping in mind that this MOSFET has to switch 220W of power (which produces heat needing be dissipated) might help.

Past
Reply to Step 1: I grabbed a new multimeter and tested the leads from the motherboard (Disconnected them and tested it), put the Ohm meter at 200 ohms, and it showed 2.4 Ohms. I also wiggled the cable while I was measuring and found little to no change when moving the cable. (I forgot to send a picture, but I’ll include it in my next post)

Reply to Step 2: Didn’t apply since there was not infinite resistance.

Reply to Step 3: I’m a little conflicted on this. The bed contact points have a silicon hard gel covering them. And I’m worried on damaging the board by prying off this residue. Would you recommend a solvent or something to take it off? Or should I just stop being a woos. :rofl: In my understanding from what you said, it sounds like the bed is functioning the way it is supposed to, reading 2.4 ohms on my multimeter.

Present
Ok. So here is what I have been doing the last couple of days/hours. I started disassembly and reassembly of my 3D printer to see if there was anything I was able to find or figure out. I actually managed to find that the 4 prong connector to the black control box was a little more loose than what I had previously thought. I tightened it up, ran a PIN test as mentioned in the first step (Did not save the new configuration because I didn’t want to change something). Everything was working fine for a practice print, and roughly 8 hours in, “Thermal Runaway” error.

This time however, I have Octoprint logs and pictures that might help the situation. Another buddy that I have also been asking quite a few questions thinks that it now might be internal with the board or program. So really worrying.



Thermal Runaway Error Log 7-13-24 (1).txt (9.6 KB)

Where do you think I should go from here? Sorry if I missed something. And thank you very much for both your patience and help @Bjoern.

Edit 1: I also wanted to point out that the screen indicating the thermal runaway was off, and not actually 190 & 57 degrees Celsius. The temperatures were ice cold, not hot when I touched the hot surfaces later after I noticed it had stopped. Neither the bed nor the extruder were hot.

Edit 2: My friend who also has experience with 3D printers mentioned that there could be a bug in the software, because it did not indicate a thermal runaway. Not really sure where he found this out (probably the Error Log I included above), but that’s what he believes. If that’s the case, is there a way to update my printer’s firmware? I’ve never done something like this, so a step by step would be greatly appreciated. Thank you again!

Edit 3: Just noticed that there has been a change in the “Thermal Runaway” screen popup. Not sure what this means but yae. :joy:

OK, let’s see:
Past Step 1: Cheap digital multimeters usually come with slow analog-digital converters, therefore “little change” is a strong indicator for the problem. Addionally, it is highly likely that the bed connector suffered from mechanical impact if the connection cover has been loose.
Open the bed connection cover, remove the hard silicone carefully using tweezers or long-nose pliers & re-solder the contacts. Install the cover. Re-run bed PID-tuning. After the problem should be solved finally.
There is no reason to worry about anything: You did not mention which firmware is currently installed on your SV04 - I suppose it is the stock firmware. Judging by source code available Sovol did not put much effort in their firmware to support SV04 host operation. There are known host report issues which have been fixed in custom firmware versions. You may want to read this before changing the firmware.