Sovol klipper screen dead after update

I have a sovol klipper screen installed to my SV06 plus, which worked fine after install.
After some time, mainsail offered several updates, which I accepted (I can’t exactly tell, how they were named, as they don’t appear right now).
The reboot after the update kept the screen completely dark, no matter how long I waited. Green LED was blinking, blue LED was on. It didnt try to connect to my wifi and connecting to the service USB-port (only accessible after opening the cover) didn’t show a serial device. It was obviously stuck in a boot loop without possibility to connect to it.
Gladly, inserting a USB-stick with the screen firmware (“armbian-update.deb”) brought it back to live.
Today, mainsail again showed the update option.
After updating the system (I remember an update of xorg), the screen stayed completely back again. Though this time, network was at least available (but it wasn’t able to the printer).
So I started the firmware update again (as above, using the USB-stick) and the screen came back.

  • What can cause this?
  • Anyone had the same experience?
  • How can mainsail be forced to check for updates again (to be able to explore further)?

Seems, that I am alone here with the Sovol problems?
Just in case, anyone gives more than a f*ck:

The problematic part seems the kernel update from “22.05.0-trunk” to “23.02.2” (updating from kernel-5.x to kernel-6.x):

root@mkspi:/home/mks# apt --dry-run upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Inst linux-image-edge-rockchip64 [22.05.0-trunk] (23.02.2 Armbian:buster [arm64])
Conf linux-image-edge-rockchip64 (23.02.2 Armbian:buster [arm64])

After this, “/dev/spidev0.0” is no longer created, thus connection to the printer fails - and the screen stays black.

(Just for completeness: To do the update-check more regularly, add this to moonraker.conf:
refresh_interval: 1
enable_auto_refresh: True

I am not very positive to get an answer, but anyway:
How do I get back “/dev/spidev0.0” after the update?

Yeah, getting an answer is a bit tricky. I ran into the same issue and am now trying to reflash my screen (with the firmware on a usb stick), but now i ran into other issues :frowning:
And by mistake i deleted the moonraker.conf file, so now nothing works. I can only SSH into the printer…

I think I can top that. I started with the same issues. Jump forward to after the Armbian update via usb. I was then given MCU errors before I finally gave up for a week. Come back a week later & now I don’t even get the blue “Working light”… just solid green light & literally nothing else. its like it is now the worlds shittiest night light or something, because it provides no response to SSH, Wifi. The screen is still black. None of the ports USB A, C, or otherwise appear to even acknowledge a connection. Can’t flash from usb. can’t do anything as far as I can see. Other than as mentioned leave it next to a toilet as the most expensive yet worst nightlight ever made. Truly I should just drop it in the toilet, but for no logical reason I continue to hold on to it, in the vain hope that SOVOL might not actually be a total bunch of mouth-breathing, short bus riding inbreds & might possibly look at fixing any of the myriad of issues they seem to invent… anyway, This is more of a vent than a cry for help. I’ve read enough forums, sites & alike to know that Sovol Are Deaf to all but the sound of a dollar sign made by a new hepless soul.

I’ve found some ways to restore my KlipperScreen:

Note: The KlipperScreen firmware is identical for SV06/SV06+/SV07/SV07+, it only differs in the printer.cfg, which can be downloaded separately and replaced, once your screen came back to life:

Once you revived your screen, make sure to prevent kernel either by locking it, or just don’t do any updates. See below.

Good Luck!

Option a) Reinstall the Firmware update (50MB download):
Requires an empty, max. 32GB sized USB-Drive.

Download the firmware update. It’s only available on google drive:

If the link became invalid, try to find it on Sovols product page:
Sovol Klipper Screen
Then look for
Sovol SV06 Plus Klipper Screen Firmware

(Again: You can use this one for SV06/SV07/SV07Plus as well)

Unzip it, it contains two files:
“armbian-update.deb” and “Notes on flashing the firmware.txt”
Copy the “armbian-update.deb” onto an empty USB-Drive (max. 32GB; formatted as “FAT32”, don’t use “exfat” or “ntfs”), insert it in one of the USB-ports of the screen, power it on and wait, it should come back to life.
If the screen doesn’t show anything after 5 minutes, try different USB-drives and USB-ports.

Option b) Completely reflash the eMMC (2GB download)
Requires either an eMMC-USB-Adapter or access to the serial console of the screen.

Open Sovols KLIPAD50 github page for instructions to download and install the firmware image:

Download the firmware image. It’s only available on google drive: - Google Drive
(or search the KLIPAD50 github page for that link)

There is also a link to an eMMC adapter on the github page:

You can also try to access the serial console of the screen and reflash the eMMC from there:
GitHub - TomasOlsson/BrickedSv07-Sv07Plus: This is just for users that have bricked their Sovol Sv07 printer.

Locking the kernel / Future updates:

It’s best to lock the kernel (and dtb), so future updates don’t kill your screen again.
Either use ssh or putty to log into the screen, then enter
sudo apt-mark hold linux-image-edge-rockchip64 linux-dtb-edge-rockchip64

Or follow these instructions, it uses “armbian-config” to lock the kernel+dtb
and also shows, how and what you can update without killing the screen:
GitHub - 3DPrintDemon/How-to-Update-Sovol-Klipper-Screen-To-Latest-Klipper-SV06-and-SV07