Safe to update Klipper?

While playing around with the printer, I decided to install Mainsail alongside Fluidd. I noticed in Mainsail there was an update section on the dashboard, which gives the option to update Klipper and Moonraker. However, they both give warnings about possibly breaking the interface. Has anyone else attempted this, and are there any “gotchas” that I might need to know about before performing this update? I’d rather not brick the printer less than a week after getting.

Thanks in advance for any help

Additional screenshots, since the forum wouldn’t let me post more than one in the original post
2023-08-25 12_28_08-Complete - flexi-skeleton-ring.gcode — Mozilla Firefox

Last screenshot

2023-08-25 12_28_27-Complete - flexi-skeleton-ring.gcode — Mozilla Firefox

i updated everything, excerpt the moonraker. :slight_smile:

Almost right after I posted this, I was curious if Fluidd had an update function. I found it, and it has a similar warning on the button, so I expected it to throw up a confirmation dialogue when clicking update on the Klipper software… it did not, so I got a somewhat unexpected live test. Luckily everything went find. I did run into a weird issue after updating everything else (including Moonraker, which also worked fine for me), which was that Mainsail itself threw an error about the git repo. Turns out the root folder had it’s own git directory (/.git), which pointed to a project I wasn’t expecting. Looks like the MKSPi default install used has its own github repo, which has been updated multiple times since the software on my machine was installed. Curious…

Anyway, for those wondering, it looks like doing the software update through Fluidd or Mainsail work just fine.

Hmmm my printer says something in chinese (i think) and thats it. Where did you find the option in fluid?

the options for updating sw/fw weren’t visible in fluidd for me, not until i’ve put mainsail, at least. now i’m waiting for an answer from sovol regarding the armbian, i’ve tried updating it with armbian-config and just died on me, after rebooting. i’ve tried looking for the armbian image for this system, but it’s not easy to find something related to sv07, ffs.

That sucks… not sure what sovol uses but github doesn’t have anything for the SV07

Under “Settings”, at the bottom of the page is “Software Update”

I’m not sure what you were trying to update with armbian-config, but when I used it to change the machine’s hostname from mkspi, it seemed to work fine.

I don’t think this is the entire image, but the /.git directory has a config file which points to this github repo: GitHub - MS1987/SOVOL_MKDEB

It seems to have a fair amount of the klipper software setup after armbian is installed, but I can’t be certain.

Thanks for this repo, i’ll check it out. Aparently, i can still connect to the armbian via serial, so it messed up only the klipperscreen for me. :joy:

Fluidd, Settings, stay in General, scroll to the bottom… no Software Update in mine :frowning:

the only stuff that i could find changed in moonraker by sovol was adding support for their custom slicer and adding a line that turns on the aux fan at line one if your not using their slicer. so updating moonraker will mean it no longer works with their modded cura and you will need to either add a macro to link the aux fan to the main one or add a line to your start gcode to turn the aux fan on.

these are the M106 and M107 macros i use: aux fan macros, remove the if statements if you don’t want to setup the virtual pins stuff

for what it’s worth, i am now running my SV07 with fully stock software because i messed up and broke my screen so i had to switch to a raspberry pi while i try and buy a new screen from sovol and all i copied across was the printer.cfg (and some klipper screen stuff because i like the layout sovol made)

I realized this is because the update manager has to be enabled within the moonraker config: Configuration - Moonraker

What changes did you make to moonraker.conf?

Technically I didn’t - it happened when I installed Mainsail via KIAUH. That added two entries to moonraker.conf:

[update_manager mainsail-config]
type: git_repo
primary_branch: master
path: ~/mainsail-config
managed_services: klipper

[update_manager mainsail]
type: web
channel: stable
repo: mainsail-crew/mainsail
path: ~/mainsail

It seems after these were entered the update software section in Fluidd was made available, and included software outside the mainsail-config and mainsail repos, as if just enabling update_manager allows it to auto detect other software as well as that explicitly configured.

OT: What advanteges does mainsail bring you over fluidd?

After having used both of them, I’m finding I tend to use Fluidd more than Mainsail. They have roughly the same featureset, but I’m finding that certain features in Fluidd are placed more conveniently for my preferences. Honestly, I suggest you just install Mainsail and play around with it.

The easiest way to install is to SSH into the printer, run sudo ~/kiauh/ and use this tool to install it

I tried updating my Klipper last night and it nearly bricked my printer. The touch screen stopped working, though it seems others have run into this exact issue and thanks to their guidance I was able to rescue the machine without much fuss.

My advice is if it ain’t broke don’t fix it, I’m surprised there isn’t more warning about not updating since the interface seems to suggest that updating is the proper course of action.

EDIT: The printer originally came with Fluidd, but the fix has changed it to mainsail. Is there a guide available on how to switch it back?

what did you do to fix it? a link to the guide you used will help understand why it changes and how best to change it back