Safe to update Klipper?

I followed the instructions in this Reddit post. In my case I was still able to connect to the printer through the web interface, but it gave me an error that said “MCU ‘rpi’ error during config: Unable to open spi device”

I used the first method they provided to restore my printer to normal though the web interface now uses mainsail. This isn’t a huge deal, I’m happy that the printer works again but it doesn’t recognize the USB webcam I’ve hooked up. It worked fine in Fluidd and I was setting it up for some timelapses, which I originally blamed as the problem. I thought I had installed something incorrectly and broke everything but it turns out it was in fact the update.

I haven’t looked through the fix to see why it might have changed the default web interface to mainsail, but getting it back to fluidd should be pretty easy. It involves changing the nginx config files.

SSH into the printer, ls /etc/nginx/sites-enabled, there should be a file for both mainsail and fluidd here. In each of these files will be a line near the top that says “listen ”. Since Mainsail is the default coming up, that will be set to 80, and fluidd on something else, perhaps 81. All you need to do is change the port number on this line so that fluidd is listening on port 80 and mainsail on some other port (they have to be different otherwise you’ll end up with a conflict that will cause nginx not to start). Once you have changed these files and saved them, run systemctl reload nginx, and fluidd should now come up when you open your browser to the printer’s IP/hostname.

Hopefully that helps

1 Like

looks like that is a full reflash, not sure why they changed the default web interface but it does explain why your camera stopped working. if fluidd is still installed then knw257’s advice should work, if not then i beleive the stock install includes Kiauh so you should be able to use that to install fluidd. you will need to uninstall mainsail first (or follow knw257’s solution once your done) to let fluidd use port 80.

im still not entierly sure how updating your klipper bricked your printer though. in the reddit post they updated the whole os not just klipper.

Thanks, that worked a treat, I will be saving this in case I ever want to switch back in the future. I may have been too quick to blame mainsail as the camera still didn’t work until I reinstalled µstreamer.

This is true but in my searching I found others that warned against updating (ex. here and here).

I managed to reinstall the timelapse stuff and everything is working again so I really don’t think it was at fault. I may try updating the firmware again in the name of science now that I’m familiar with resetting everything but in any case I appreciate everyone’s help and patience, as I am very new to Klipper and linux in general.

thanks for the links, interesting to see that this seams to be a common issue. i must have just gotten lucky since i did everything both you and the people in the links said they did (the 2 in your recent comment, not the one about updating the whole os) without any issues. i wonder what was different about my process/system that made it not break? oh well, glad you got yours working

I retrieved the 9/13 armbian-update.deb from the Sovol site, Created a fresh 8GB USB thumbdrive and added the deb to the drive. Powered off my 7 Plus, inserted the thumbdrive and rebooted. Got the normal boot sequence and update as in the mp4 they shared.

Unfortunately, after reboot I now have a bricked SV07 Plus.

@sovol3d, @Sovol.Claudia - what’s my next step?

can you add some more details on what “bricked” means here? is it not powering on at all or is it in a boot loop or cant connect to the printer?

The Green LED lights, the blue LED stays dark, the display never comes on (even the backlight)

Did you have it connected to wifi before updating? If so, do you see it connecting to your network? Can you SSH into it?

If you didn’t connect it to wifi, or it’s not connecting to the network post update, you might try using a USB cable to connect to the terminal via PuTTY. Instructions for this are available at GitHub - TomasOlsson/BrickedSv07-Sv07Plus: This is just for users that have bricked their Sovol Sv07 printer.

In my case, it’s not getting the the boot sequence. I suspect that the grub config was corrupted. I can’t get in via the download port - because it’s never getting to the init stage.

At this point, I don’t see a way to get to the system without replacing or reflashing the EMMC boot volume.

In my other post showing the MKS board inside the touch screen, I inked to an eMMC to USB adapter provided by Makerbase on their AliExpress store for $3. I also saw a post somewhere, I think on the SV07 user group on Facebook, where someone figured out how to solder the eMMC pins to a microSD adapter and plug it in that way.

The github page I linked also describes a process that it looks like might boot to USB as default, and provides a link to the img of their printer eMMC, which might give you a way to recover even if the kernel doesn’t boot from the eMMC directly.

Thanks - I saw those and have ordered the adapter from Ali-Express as a just in case and for experimentation later down the road. I’ve tried connecting via the USB Serial link, but the printer never gets to that point in the process. I also built a thumbdrive from Tomas’ image and connected it to the Downlaod port (USB-C), but still no joy. I suspect that reflashing the EMMC or receiving a replacement from Sovol will be the only resolution here since we don’t see the boot screen from the MKS board.

Also, the Sovol Team are working hard to help me get back on my feet with the unit.

I’m curious - there are two USB-C ports on the board, the one labeled “Download” is hidden by the case. I was able to use the other USB-C port to connect to the serial interface, which seemed to show boot info even before the kernel was loaded. Granted, I saw this after using the terminal access to issue a reboot command, so I suppose if you’re powering it up there may not be time to connect the terminal before it gets past this point, but you could try using the power button on the side of the screen to see if you can trigger a reboot that way.

In any case, with the number of people getting their units bricked after running the update, I’m avoiding it for now. Hopefully they’ll roll out an update that fixes this problem, and one that doesn’t overwrite my printer.cfg

1 Like

Once I get the adapter, I’m going to run through the upgrade procedure and monitor what’s happening. I wonder if there are more steps than just waiting for the reboot that we’re not aware of.

Thanks for the pointers and the commiseration :+1:

The adapter arrived and I flashed the image from Tomas. Everything’s back to normal.

For the post mortem - the grub update seems to have been the failure point on mine. The boot info was scrambled.

1 Like

Old thread, I know. Stay with me.

I decided to dig into the code packages installed on my Klipper screen (added to my SV06+) and I found some of the packages are direct installs with no modifications. Others have slight modification that don’t seem to have any issue with compatability. It seems like they could all be updated easily enough.

Then there is the KlipperScreen package which is heavily modified in a lot of ways. I am still working on tracing the base package source commit.

check out my notes here.