Second Extruder out of Sync

After replacing the extruder on my sv02 i attempted to calibrate my e steps to make sure my extruder motors were working as intended. When I calibrated the left one I went to the right one and asked for 100mm of filament as a test just like the left motor. But what came out was severely less than 100mm. If i try and calibrate to the right motor my e steps have to be set to a ridiculous number and then the left motor will extrude far too much. It would appear that these two motors are somehow out of sync with one another. I have tried to solve this issue by replacing both the motor and the wire but no luck these two motors are simply out of sync and i desperately need help.

Hi @MakeoutFuneral Sorry to read about the trouble. Based on your information, we have a few questions and suggestions for you to consider. First, did you replace both motors with ones that have the same specifications and parameters? If not, this could be causing the issue.

Secondly, it’s important to note that the SV02’s E-step is shared by both extruder motors, so you only need to calibrate it once.

Lastly, we recommend checking the voltage of the extruder motors on your measurement board. You can do this by using a multimeter, placing the red probe at the cross screw position next to the extruder motor driver (as shown in the reference picture), and placing the black probe in the SD card slot to measure the current voltage.

We hope these suggestions help you resolve the issue with your extruder.

Hey glad to hear from you.

I double checked the motors and I believe they are the right specifications. They are rated for 23 volts just like the stock ones. I only replaced the motors after encountering this issue and even after changing it the problem continued on the same side. The new motors are creality 42-40 motors.

Secondly, I do know the esteps should be calibrated once for both motors. But its the fact that one seems to be lagging behind the other despite calibrating one side that should be the same as the other side that is the issue.

As for the Volts i tested both connections and found that E0 is giving me 22.9V while E1 is giving me 22.8V. I also saw that swapping the connections for the motors switched the issue from the left side motor to the right (I included a picture as to which wires I switched). I am still perplexed as to what is going on.


Thank you for your clarification both here and on Facebook group. The voltage values you currently have seems incorrect, usually around 1.2 volts. To answer your question, it may be helpful to have a picture of the voltage measurement you’ve taken in order to better understand the issue. Thanks in advance!

apologies I misunderstood the directions. Tried it again and it looks like i’m getting 1.37v on both of them. (Included a photo just to make sure im doing it right)

Also reflashed the firmware and the problem still stays.