On my second SV07+ won't level, won't z-level

I sure wish Sovol would recognize there is an actual printer called the SV07+… Ok, this is my second SV07+. Had to return the first due to massive extruder issues. This one I had working really well! Had many prints on it, but realized the first layer was a bit too close to the bed. So, I adjusted it so the first layer was perfect. That was when all heck broke loose! After several prints of 1st layer working perfectly, every other print would glob because it wasn’t touching the bed.
Started the bed leveling process and things just weren’t working right, it was a complete moving target. So, I made sure the wheels were not too tight or lose, tightened all the screws I could find and did the z-calibrate, then the bed level. Still, it just wasn’t working. So, I hit the “screws adjust”, wrote down the three values, touched nothing, hit the “screws adjust” and the values changed. touched nothing, screws adjust again, values changed, over and over. Here was the resulting values after 8 goes. (NOTE the values are bottom right, top right, top left for each set:
.18, .18, .18
.19, .19, .18
.20, .20, .18
.20, .21, .18
.21, .21, .18
.22, .22, .19
.22, .23, .18
.23, .23, .18
.23, .24, .18

I would expect maybe a slight fluctuation, but ever increasing values? Then I decided to just do some z-calibrates. Each z-calibrate always started at .03, it would eventually get down to the .005, then another go it would start at .03 and get down to .005, then another go would start at .03, etc, etc. I would think that after adjusting itself, it would stay at the .005 or close to it. Not always resetting itself to .03.

What can I do? I’m about to just return this one as well and go with something else, but when it was actually working for 4 days it did some great prints! I’m not going to try for #3 because the price has increased and Amazon doesn’t offer replacement, only returning and rebuying at the new price.



Sovol has not bothered to create Titled sub forums for the 7 or 7+, clue 1

If you had the presence of mind to buy on amazon, they have great parts support imho


My contact was Candy, very helpful

proly best to return it tho, the company is a creality parts bin assembler, that got very lucky with the sv06 being reliable and decent

the rest are not, and nuthin is supported in any meaningful way.

I only had to harass there YouTube channel constantly before they finally said that they would refund me, but they are shorting me on that too.

Seriously, who sends a person one tiny piece at a time, they literally sent me a piece of broken Pcb with a 5 pin accelerometer lead on it.

Or instead of sending a new Extruder send a part and watch someone wreck things since unlike other companies that have instructions and a large following I do not know what Sovol’s point is.

Why even bother putting steps on bags if you are not going to bother checking the screw sizes.

Somewhere they got the idea that I’m

  1. Know anything about electronics or am able to solder, use Linux or anything else.

I Originally ordered a S6 and within 24 hours asked to send a SV07 instead and paid $60USD for the SV07.

After 6 months of them sending me a part at a time from China as it had successfully printed off a few Calidragrons and is always broken, so send a new Emmc chip for me to install, send a hotend, send a new probe, send the same update to Canada over and over again and me not being able to get this stupid thing to print properly they finally said that they would refund me.

It’s completely bricked. I used the MKSPI ISO to try to bring it back to life and had someone write it all out but all I get is a readout and no ability to login via Putty or through an Emmc adapter.

Got step one to work, now only if I could login via Putty again.

At this point I have no clue how to reflash it.

Bought an Emmc adapter.
Think there is an issue with my laptop since God knows the amount of different things that I have tried to do with it.

The MCU crashed and said that a sensor or something is thermal overload.

I think that since I have bashed them constantly that they just don’t want me bringing light to their lack of support.

The same problems happen to everyone it seems. Their are 3 Github repo’s specifically for the SV07 and Plus that I know of.
Logically if you have a MKSPI V. 1 Klipper Board one would think that you could reset it and then flash their firmware back on.

Beyond my abilities.

I have tried everything.

Will be waiting for them to reimburse me, sent them a Screenshot of the error in amounts.

Why do people use Github Repo’s in an attempt to get there machine to work?

Because it is Comgrow /Sovol /Creality does not support there own products.
Yet they make silly YouTube videos and force you to use Meta/Facebook for support.

Well an engineer from Creality started Sovol, QA is non-existent and I wish I had just stuck with the SV06 or the SV06 Plus as they seem to be the only ones that work.

No support, have to go on Steal your Data Facebook for any help.

Or keep posting on YouTube shorts and livestreams.

Seriously how did so many other companies explode in userbase as of late. Offer similar products at the same price point.
With a huge community and support.

Bambu Labs isn’t perfect either but they generally work.

Everything is old on Sovol’s, firmware from old dead legacy forks and they are made at the same place as Creality and Comgrow yet the prices change all the time.

If you live in Eastern Europe/Asia or the US you might be able to find replacement parts but if not good luck with that.

Why did they even release the Prototype SV07 and then the Plus was out all over the place but their official website.

I just hope that they come through with the refund in 5-7 business days.

Then again I got so pissed off by owning this thing and trying to get it to work that I know all about 3D printers now.

DJI engineers made Bambu Labs, Elegoo comes in and gets a ridiculous amount of people buying there products.

At least if it’s Creality or Elegoo you can get parts for it.

No upgrades for these.

Do not try to make it better unless you are capable of building a Voron from nothing.


Anyone have any ideas?

The firmware is not corrupted as the lights are blue.

Cannot login to give the commands to build it like as if I just bought the Klipper board and wanted to install it to the machine.

Regardless something is causing the root problem with the MCU.

Not sure if my computer is the issue as I can login and see it trying to do stuff but cannot enter any Linux commands.

It shows up as COM 4 and I use 150 0000 Baud rate.

Too dumb for this stuff.

Sovol is not connected to creality in any way other than they used to purchase parts from them. They are their own complete entity. Sovol asks in facebook groups what the most important thing the community wants when it comes to releasing a new printer. The #1 request has always been the price to be as a low as possible. I would recommend joining the groups for further support. I hope you find a solution to anything you may need. Happy Holidays!

Sovol is not a part of Creality and their support is second to none. You should visit the facebook groups for further assistance. Anyone getting into 3d printing should not only prepare, but be willing to work on their own machines. Anyone unwilling to learn should just stay away from 3d printing altogether. Its not something you just press play and it does everything for you. That type of 3d printer doesnt exist anywhere on the planet. They will all need routine maintenance or repairs at some point that will require the used to “get their hands dirty”. I look forward to helping you resolve your problems through the groups changing your whole outlook on things. There are many of us there that are willing to help anyone with a respectful attitude towards wanting to learn more. I hope you are able to have the negative outlook turned around for you asap. Hope to see you there. Happy Holidays!

1 Like

Hello gregma,

I have had a SV06 for a year now and have some problems that Candy (amazonus@sovol3d.com) willingly helped to solve.

Perhaps your problem is the inductive sensor defective and fails after warming.


I had considered that. Only causing problems on one side of the printer I kind of ruled that out. I still think it’s the gantry, but who knows.


Hi all
I have had immediate (within a few days) help from Sovol, spares have been no problem either.
I have had my SV07 since it first became available, it worked flawlessly from day one, but, during a print (some weeks after) The gantry belt came adrift from the carriage, the copper clamp had broken, I contacted Sovol and they sent a new belt and a bunch of ferules.
I had a one of the thermal sensor wires break (entirely my own fault) again Sovol sent me a new heater block nozzle and sock all free of charge. I like a number of Sovollers had an MCU connection problem which again Sovol helped out, It turned out to be interference from the 5volt terminal in the usb cable, so I covered that terminal with insulating tape and used the next usb socket, problem solved. Not had any trouble since
My experience with Sovol has been excellent. It may take a few days for replies and delivery’s but that should not pose a problem, I should add that I deal with Sovol in China, very helpful guys.
HappyChristmas all

Yesterday’s action’s affect Today’s, both effect tomorrow’s

1 Like

Hi Gregma,

Have you tried to disengage the Y belt and move the bed back and forth manually?
Sometimes the plastic wheels become deformed if too tight. In that case you will note it as bumps while moving the bed manually.


1 Like

Y axis v-wheels were adjusted and roll quite well. Z gantry seems to be the problem. It’s a moving target.


We had similar on our SV06+. What we found was the mount for the leveling probe was cracked and letting it wobble. The other issue we found was the fan for the extruder was gumming up letting the extruder overheat causing the heat break to transfer heat into the gears and clogging everything. All that caused a filament build up between the extruder and the probe cracking the mount.

Sovol has really dropped the ball and is about to crash and burn if it doesn’t get it’s act together-.
There SV06/SV06+ are Basically Prusa Clones (Hardware/Software) which why they work (even they screwed the first Batch up). The SVO7 is different Tech and i don’t think they have expertise to produce reliable printer, from what I’ve read lately your basically flipping a coin to see if you get a printer that works-.

My Advice would be to return it and get something different – anything with a strong Customer/Online base for support and Spare Parts that are easily available to buy-.

Beside the Badly Bent Bed on my SVO6+ its a pretty solid printed-.

All the Best & Merry Christmas

Could you please tell us the order number or give us a payment screenshot?
We need to check if your order comes from our shop.
Also it’s best to give us a video or pictures to show that problem,then our tech could check what the problem is.
PS:take a picture of the serial number.

Best regards,
Sovol After Sales Department

website: sovol3d.com

Follow us to get exclusive 3D printing information
Sovol Official User Group: https://www.facebook.com/groups/sovol3d
Facebook Page:https://www.facebook.com/sovol3d
Youtube: https://www.youtube.com/channel/UCsKntuwh7dhAGep8R6kasog


For what?

I only had an extruder issue and you already sent me the replacement parts. If this is in reference to my post about the mks board, I don’t see a fix from Sovol short of adding a larger enclosure with a fan to fix that disaster. I fixed it by replacing the mks board with a Bigtreetech pad 7.

Well, looks like I wasn’t hallucinating. I thought it had something to do with the z axis. Tried one last time before boxing it up. Heard a strange clicking sound when the gantry moved up and down when doind a z align. Here is what I found… Looks like the right screw is coming right up through the top. Pics… Top of left, top of right, bottom of left, bottom of right. And less than 2 weeks useage.

Maybe the motor side of the lead screw coupler is loose? If so, and it comes loose again, I would add non-permanent thread locker to the set screw threads.

It wasn’t. I tightened all the screws. It’s being boxed up and sent back. Frist printer lasted a week. Second printer lasted 2 weeks. Ordered a 06+. Hope that experience is better! Going to miss the meanwell PS, klipper, wifi, tool storage, etc. But if I can keep the 06+ for more than a couple of weeks, I can hopefully begin to make mods if they exist.

All valid points save 1

An excellent company I discovered searching for artillery parts.

PartsBuilt 3d

Jonah & Hannah now have most of the sovol bits in stock, at your door in 2~ 3 days

Zero kudos to sovol, to be clear.
My opinion of the company has changed a bit, I think the regular 6 was a lucky anomaly in a lineup of CCJ produced with a single feedback metric

Units shipped