Octoprint causing sv06 to lose its mind occasionally

For some reason when I run octoprint on my sv06 it works fine for a while until randomly the printer starts malfunctioning.

  • X axis sensorless sensor goes wonky
  • autohome doesn’t work all the time
  • Printing fails even with the same file printed from the sd card.
  • Other oddities

To fix it. Unplug USB cable, turn off printer. It starts working again. Only twice I’ve had to do a eeprom init to solve the issues.

Printing from the SD card works just fine, however, it’s so much easier to use Octoprint

Any thoughts. Using the firmware that came with it back in early Jan.

Any chance your raspberry pi (assuming you’re using a Pi) is overheating or showing under voltage warnings (both should be showing up in OctoPrint’s UI)? Also, have you tried swapping the USB cable just in case it happens to have an issue?

I don’t know what exactly would be causing your issue, but I’m using the firmware from around that time and have been printing literally everything via OctoPrint on a Pi 3 connected to it. I haven’t had any of those issues. The only issue I’ve ever experienced is if I pause & resume a print via OctoPrint’s UI, there is a chance the printer starts going into slow motion. I’ve seen that on other printers as well though, so that isn’t unique to the SV06. That’s the only issue I’ve personally hit with OctoPrint on my SV06 after maybe a hundred or so prints.

dont know if this could help, but you can try fixing the auto-homing parameters first:
its the “advanced conf->TMC Drivers->sensorless homing” or smth, and set both to 68 (1 of them is 65 for some reason and then it starts to bang and grind the x-axis at every launch)

This sounds like it may be back powering from the printer…intermittent odd issues are consistent w/that.


Fix: Easy fix w/a little electrical tape and tweezers. Worth a try.



Bought an usb powerblocker as someone suggested it’s back powering the printer.

And now, it’s no longer doing odd things and is working well. BTW I’m using Octpi for Android on an older phone and it’s working well with both printing and timelapse.

Thank you all for the suggestions looks like we’re good.

Current Mods:
Z-axis rods stabilization with bearings
Washers under bed supports to level out the right side of bed that was too low
Filament wrangler
TPU Feet on a fatigue mat to isolate vibration
Cable chain for XY to keep it from scraping on bed

After these updates and a little tweaking of Cura settings I get reliable and beautiful PLA prints at 65mm/s and if external surface quality isn’t needed - 100mm/s. However, 100mm/s it looks like a 1970’s economy car going over a pothole infested road at 60mph. I don’t want it to shake itself apart, therefore I keep it at 65mm/s and under.

Thanks again.

Hi @eeper,

I am currently trying to get octo4a to connect to my SV06.

Can you tell me which Serial settings you are using? When using auto/auto i cant find the printer :frowning:

I’m using the default settings. I did end up getting a powerblocker USB adapter so the phone wouldnt power the sv06 board. Much more stable afterwards. I’ll check to see if there is a thing else I can find that may help.

Get BlueMail for Android

My powerblocker is on it’s way, for now i tried taping the 5V pin with electricians tape.
I will also try reinstalling octo4a, perhaps something went wrong there.

Reinstalling octo4a did the magic, my octoprint is online :grinning: