SV06 Firmware UPDATE

🥸-Updated SV06 Firmware-🥸


  1. Improved auto-leveling function.

  2. Added the function of saving z offset automatically.

  3. Adjusted the driver parameter of the motors.

  4. Activated the SENSORLESS_ BACKOFF_MM function, reducing the risk of the X-axis hitting the y-axis.

  5. According to the customer’s suggestions, changed the G28 XY command to G27 so that the bed will move forward after the prints are finished, which is more convenient to remove the prints.

Have a look and enjoy it 👉👉

1 Like

Hi, I have serious isses with AutoHome on firmware SV06V2.0.0A_2.24. X axis doesn’t detect endstop anymore.

  • Did a “Reset Defaults” in configuration menue
  • Tried to increase stall threshold with M914 X240 . Then M914 to review the settings. But the motor continues to skip steps until firmware reports “Homing failed…”
  • Tried to update firmware again (seems to not do anything)

Any advice would be appreciated. Firware version SV06-v192A-1028-1.3 had no issues.

@sovol3d please add links to previous firmwares with complete changelog for each version. We need it in case we want to revert to previous firmware.

@sovol3d Also please update source code with the latest changes

@kord2003 Thank you for your feedback, the request is forwarded to the firmware developers.

Hi Devirex, sorry for this causes you trouble. I’ve submitted your concerns as a ticket, and I’ll get back to you if I get any feedback.

Hi @Devirex Sorry for the late response.

Based on your description, we’re not entirely certain about the issue you’re experiencing. In order to assist you better, we suggest that you try initializing the EEPROM option in the menu. This may potentially resolve the issue you’re facing.

If initializing the EEPROM option doesn’t solve the problem, we kindly ask if you could provide us with a video demonstrating the issue. This will help us understand the situation better and provide a more accurate solution.

Hi, i tried to flash the 192a again. After hours of trying i found out that each name of a single firmware file on the sd card has to be unique and only will be flashed one time. So i after renaming the 192a.bin file to firm2.bin i was able to flash the old version. The issue persisted. I did a configuration reset. The issue persisted. I downloaded a different firmware where i found the “erase eeprom” option in the advanced menue and after that it was working aigain. So erase eeprom will also help on the stock firmware i think.

1 Like