X-homing fault?

Hi, I just got my SV 06 and hope to get and share info with other users.
So, hello to all.

First problem: My Auto Home function delivers an end position in X which is way out of middle. After homing the printhead returns to the middle of the bed. and I expect that it is at X 110 and Y 110. My printhead stays at
X = 85 and I can’t find a menu item where I can correct.
This homing error can also be seen for bed levelling. Fot the left 5 positions of the 25 points grid I always have X = -10, meaning that the printhead travels to the stop and stays there.
So the 25 points grid is shifted to the left by appr. 25 mm.

Hi @luwi84,

I’m not with Sovol, but I’ve been digging into my SV06 and here are a couple of ideas I have based on what you are reporting -

It’s way out there, but double check and make sure that you didn’t mix up the Z1 and X connections (the cables are labeled).

Also, make sure that your X axis belt tension is proper.

Finally, go to the Configuration menu option and select “Restore Defaults”

Otherwise, This could be a failed stepper motor or a bad controller board (I would suspect the latter).


No, X and Z1 connections are ok.Belt tension is ok.
In configuration there is a menu item “Set Home offsets”. When I do this, it responds “Auto Home first”. I do this and go to “Set Home offsets” again. Then I see the info screen and get message “Err: Too far!”
X and Y movements are ok. For both I can move between 0 and 220.
I hope that this error report gets seen by a Sovol expert.

Hmmm, just to make sure, did you try the “Configuration” → “Restore Defaults” menu setting?



User here as well. Did you try loading the latest firmware on the printer?


Hi, “Restore Defaults” has no effect.
And for latest firmware: I tried: No change.
After Auto Home the info display shows X=85 and Y=135. And that corresponds with the actual printhead position.

BTW: After inserting the SD card with the latest firmware and powering up; shouldn’t there be a response text in the display? I get nothing, so I have to assume that the firmware got flashed.

I think I"ll contact Sovol support now officially.
Happy Christmas

Problem partly solved:
The only rpblem is that the bed leveling grid (25 points) is not centric but moved to the left. Leveling is possible nonetheless.
All other functions ok. Prints very good.
So, even though there is a fault, I can live with it.