Octoprint and SV06 Plus Issues

I have recently set up Octoprint for my SV06 PLUS and, though most everything is working fantastically, I have encountered two main issues, one has been solved, the other I want to ask other’s opinions on!

  1. First, the solved: the raspi backfeeds 5v to the printer, so if you turn the printer power off, the display remains on. Apparently others have found this causes issues and the quick diy solution is to cover the 5v pin on the USB.

  2. Second, the unsolved. The printer freezes and becomes unresponsive when I send certain commands from octoprint: “home”, “pause”, and “cancel”.

A quick search reveals that this could be the same firmware issue that @jamby notes for the SV06.

Can anyone confirm this? Does anyone have a way to solve this problem?


I have some more issues with sv06 Plus and octoprint (changed from SV01 to SV06 Plus):

cant use bed leveling plugin, with gcode G29 bed leveling starts via plugin an finishes after 25 points of mesh, but than freezes and does not return mesh to octoprint. Its like the printer ist waiting for a command, but I do nit know, which one.

another major issue:
I can manage the printer via octoprint, start and cancel jobs an so forth, but my printers screen is inactive the whole time. It is not showing, that there is a print working, I cannot make adjustments as the printer seems to not know that he is busy. Only can change temperature for nozzle an bed via display.
I told my octoprint to show actual layer via a plugin. Works fine on SV01, does nothing on SV06

Any solutions?

1 Like

Following on @TheKiter,

I concur on both points and am experiencing the same: the printer does not register that there is a print in progress. This lead to a near disaster when I attempted to navigate to the level menu to adjust the z offset on the fly while mid 10 hour print-- the printer stopped the print and begain auto-homing, as it does when you enter that menu-- which resulted in the extruder unit jamming into the print and torquing x axis rods. Luckily, except for knocking off my fan and pushing up the inductive probe, the printer runs flawlessly after a re-leveling and going over. I had to tighten the extruder to its mount as it came loose also.

I am actually quite impressed at the robustness of the printer handling such a thing.

But would like to avoid this happening again, any thoughts would be very welcome!

Same issue with Octoprint. Almost a dealbreaker as I can’t cancel, pause, or live adjust Z while standing in front of the printer.

Is the issue octoprint isn’t working or is it if you start a print through octoprint you lost control from screen? Until the new firmware is ready from marlin you may have to suffer with the rest of us.