Another Post With Leveling Questions On The SV04

Hello. Looking for tips on leveling the SV04.

I notice the instructions mention heated bed in leveling guide. I don’t remember this on the Ender3 Max I used before. So, now I am heating the bed to 60°C before leveling. Do you? These are the steps I am taking to level:

Adjust right extruder all the way up. Move bed adjusting screws so bed is lowest setting and rotating same knobs one turn raising bed slightly. I then go to Settings->Leveling and let machine auto-home. I then select Auto Z-align and let this complete. I then select AUX leveling and repeatedly adjust all four corners until a slight drag on paper with left extruder at all coners. After this is done without further needed adjustements, I start adjusting the right extruder and have placed this extruder at a corner. After adjusting the right extruder so there is a slight drag on the paper, I tighten the four small side screws on this right extruder (I assume these get tightened, but have not actually read this in any guide), but I notice the paper doesn’t drag as much after tightening the right side screws on the right extruder. !

So I loosen those screws again and readjust, but same thing after tightening screws. I adjust so the paper is dragging heavy and after tightening the screws I feel the right extruder is close to the same drag as the left extruder.

I then select the House icon to auto-home. I then adjust the Z axis in the center of the bed until paper drags and select Save. I select the House icon and can usually confirm proper height of the left extruder with paper drag. I then select Measuring and let the 16 point bed detection. I then select Save (multiple times). I would think I should be good, but…

Sometimes, Auto Homing doesn’t leave the left extruder as close to the bed as I left it before. It is usually 0.05mm high. Not too bad, but it is as if there is lead screw backlash and it’s not compensated. I don’t find any notable backlash, but it kind of explains the results I am finding.

I then run the dual extruder calibration test and notice that the right extruder is running too high and have issues with filament sticking to the bed. Now, the left extruder seems to be running at the correct height, but it is running into somewhat loose filament from the right extruder, but is successful for the most part.

What am I missing - Especially with that right extruder. Should I leave those four side screws slightly loose after height adjustment? Doesn’t seem right.

Also, on the calibration test, the left extruder’s filament is a bear to get off of the flex plate. I am used to the glass plate on the Ender3 where the heated bed really grips the extruded object, so I let the bed cool and the object comes right off. On the Sovol, I couldn’t get much of the calibration filament off when cool. I heated the bed to 85°C and let it sit for a few minutes and could finally scrap off the job. I realize normal jobs will usually be taller, so there is more to grab, but is the flex plate designed so the object should be taken off the heated plate asap??

Sorry so long. Thanks for any tips!!

It seems that setting the Z-offset was missing & maybe some steps were mixed up. It should work in this order:

  1. Using the usual printing temperatures for bed & nozzle is a good idea when leveling the print bed.
  2. Use aux leveling to get the print bed in a horizontal position with minimum tilt manually.
  3. Set Z-offset to compensate distance between left nozzle & touch sensor. The paper method will roughly help to identify a 0.1mm distance between nozzle & print bed - a feeler gauge will work precisely. Save Z-offset to EEPROM iot keep it.
  4. Measure bed leveling & save to EEPROM.
  5. Finish adjustment of left nozzle before doing any leveling of right nozzle.
  6. Use aux leveling to set right nozzle Z-level by adjusting the top screw on right extruder. Keep in mind that tightening the four side screws will tilt the extruder slightly. Therefore leave some extra distance iot compensate that delta. The side screws need to be tight iot keep the same Z-level of right nozzle during printing.
  7. Adjust X-offset & Y-offset using the “Calibration.3mf” file on the SD-Card. Save to EEPROM iot keep them.

Thanks again for your help. I appreciate it.

I went over the steps you provided and found that I had the left extruder set well. All four corners and the center points allowed a drag on the paper under the extruder. I went ahead and reset each side with the included shims and performed the bed leveling routine again. I printed a small item with the left extruder only and was successfully. Great.

So, I double checked the left one after my print and it still indicated the proper distance off the bed. While I was in the aux leveling, I checked the right extruder starting with the center position and found the right extruder too high - No paper drag. I kind of expected that from how I left it yesterday, but went ahead and checked all four corners and was surprised that the right extruder had the correct height above the bed without further adjustments! I moved the right side back to center and still too high. I rechecked the left side and it still checked fine.

So, I have to wonder why the left side checks ok on all five points, but the right side only checks ok on the corners and not the center??

Supposing that all fourt side screws of the right print head are tight the observed deviation indicates incorrect roller fitting and/or dirt on the rollers. Both print heads are sharing the same horizontal v-slot aluminum profile as Y-axis. You may want to check that:

  • all eccentric roller bearings of both print heads located on the Y-axis are fitting without play;
  • the travel paths of the rollers on the v-slot profile are free of dirt on top & bottom side;
  • all roller treads are free of dirt;
  • the tension of both Y-axis timing belts is equal;
  • both print heads are moveable with the same slight resistance when the motors are powered off.

That all sounds logical. I need to look into this. Thanks.

I went through the leveling routine from the beginning and now all is working well! Thanks @Bjoern for all your help. Very nice machine!