Won't recognize firmware on card / install

I’m trying to switch to klipper.

I’ve been trying for weeks to get this firmware changed over.
I’ve tried everything. capitals in the .BIN, just calling it FIRMWARE.
I’ve used 3 different SD cards 4gb (san disk) 8gb no name and a larger card.
Formatted to FAT32 / 4096. Only file on card.

Nothing at all gets it to boot any differently. I just tried to print from the SD and that worked (same 4gb card).

Any suggestions?

Update, just upgraded the stock firmware to 1.5 in about 5 seconds.
It’s not me being an idiot (far as I can tell) and nothing to do with physical issues on the printer.

The controller won’t accept two firmware updates with the same filename or version in a row.

Try renaming the firmware file to something else - make sure the name is different than the previous file you tried to flash, no more than 8 characters before the dot and still has a bin extension and it should work.

To help troubleshoot the issue better connect a USB cable to your PC, install CH340 USB/Serial drivers and connect to the printer with a serial terminal program set to 115200,8N1. (I use Putty)

This will show a debug log of what is going on during boot up when you are trying to flash. Any errors will show up here, and you should be able to see why the controller refuses to update.

How do you get the debug log to show? When I did this, all I saw was:
Update Failed // No SD /TF Card or error…1000s of times