Cannot install firmware

My brand new SV06 Plus is not responding (display just showing the logo). I already requested help by Sovol, and was told to check if the printer can be accessed via the USB interface using Pronterface.

Pronterface can not even detect the port when the printer is connected (I tried multiple computers and multiple cables). So according to the mail I received I should reflash the firmware.

I already tried 10 differend SD cards formatting them with Windows, Linux and MacOS (FAT32 4096) but none worked. I also tried using different file names - also without success.

Is there type/brand of SD card and a naming convention which is known to work?

Also is it possible to rewrite the bootloader as there is no ICSP connection on the board?


Use a small FAT32 sd card (less than 8gb).

Thank you. I already tried 2GB, 4GB and two 8GB cards. Formatted with Windows 11, MacOS and Linux.

The only thing that changes with some configurations is the pattern of the blue blinking led (D6).

Board revision is 1.3.1

Have you checked if all the motherboard and display cables are properly connected?
If yes, probably a failed motherboard.

If you can’t connect,…
firmware update is least of your worries.

a new bord is 30 bux, or half an hour of personal time… Jus sayin