Sv06 Plus screen is stuck on the logo

My sovol sv06 plus is stuck on the logo screen when I turn it on. I just got it last month and assembled it recently. I haven’t printed anything yet.

Any idea why? I tried to flash the firmware. It didn’t work.

all I can say is that happens to find when I sometimes cancel a print, I have to turn it off and back on. If it does that on boot up it sound like an issue SOVOL needs to help with or maybe a corrupt SD card. Try removing the card and power it off and on.

Did you solve the problem? I’m experiencing the same thing.

No I unfortunately haven’t. Right now I have a fully assembled Sv06 plus without it working. Still stuck on that logo.

Unfortunately, all I did was load the firmware from the website onto the formatted SD card in FAT32, but nothing loaded and the screen got stuck. Can someone please give me a solution?

That’s exactly what I did. I have no idea how else to fix it.

I sent an email to SoVol, but they are not responding or providing any solutions. They are uploading a corrupt firmware on their download website, and the printers are getting locked up. This is crazy.

The frozen screen issue when trying to update the firmware has been resolved.
I have to say that Sovol has not responded to any of my emails and support calls, so I had to seek help on Google. After reading in other forums, I followed a lead that involved putting the downloaded firmware on a 2GB microSD card, the oldest one I had at home, formatted in FAT32, and it worked. It seems that the microSD card that comes with the printer is not suitable for updating.

Hi Im in the same boat, worked ok ish for about 3 weeks then froze on the splash screen, ive emailed Sovol who replied 2 days later asking for more info which i provided.

I got a link with firmware and instructions, but id already tried this. I explained that it appears to be a motherboard fault but got an email on Friday (Just) saying that they are sending out a new PSU :roll_eyes:

Ah well lets see what happens lol.

But at least they seem to be on the ball.


I also received a response after waiting for several days, and they sent me the firmware for the screen. I haven’t installed it yet. Do you, who have installed it, know if it’s the same as the one that comes from the factory or if it’s a newer version?

Have you done a “save settings” after your autoleveling?