Sorry, but this firmware update process SUX!

Just got my brand new SV06 Plus. Printed a benchie, worked great. Reading on reddit for hints and tips, and see that firmware 2.2.3 is already available, but my brand new machine is only running 1.1.4.

Hoping that they had implemented some improvements, I decide to update the firmware. I see a lot of folks having problems, but then saw some success if they follow the following process:

  1. delete all other files on (or format) SD card
  2. copy firmware file to SD card
  3. rename file to “firmware.bin” if not already
  4. insert card into printer, turn printer on.

So I do it. Problem is that when I turn the machine on, I get a blue screen with “SOVOL SV06” and that’s it. No indication that it is updating, let alone something like a progress bar.

The first attempt, I just deleted all other files, and only waited about 15 minutes.
The next attempt, I formatted the card, and copied the renamed file onto the card.

Saw that someone suggested a step 0: use a different SD card. so for my third and subsequent attempts, I have been using a completely different 8GB card, and waiting at least 1/2 hour. All with the same result: blue screen.

I am seeing post after post about failure to update firmware, and not just on the SV06 Plus! But I have yet to see a single response from Sovol. Why?

I had the same problem. I believe the firmware can’t be the same name as was previously used. So name it something other than firmware.bin. I imagine this is to prevent it from flashing the same firmware over and over again.

1 Like

So, literally every other post I’ve seen about this has insisted that you need to rename the file to “firmware.bin” for it to work. But sure enough, when I just left the filename as-is, the update process completed. THANK YOU! Of course, even the extremely limited documentation from Sovol on this recommends reflashing the firmware on a whim, and makes NO MENTION that the file name should be the same or that it should be different. Indeed, they talk about reflashing it to the same version, which would imply the same file name. So if it is so important to have a different file name, why don’t they frigging mention it???

Also, my printer still says it is on firmware version “1.1.4”, which is what it came with, and no where near what the current firmware version says it is (2.2.3), but I don’t care at this point. My printer came back up and I am printing something!

Hey all,

I reddit found this info, worked for me, I don’t do much command line stuff so, ymmv

clean card under 32
fat32 format
name it firmware,
in caps
dunno how this can be a thing, but it is

he went on to say often doing FIRMWARE1 works for subsequent

Just in case anyone was wondering, the reason the firmware “update” doesn’t work is because some genius at Sovol decided to named these files according to when the file was released (FEB 23, or “2.23”) instead of the actual version of the firmware! Yes, you read that right. Evidently the release firmware (v1.1.4) is still the latest.

Also, yes, the name does have to be different, but caps/lower case doesn’t matter. SO my initial instructions will actually work, as janky as they are, except for #3, where you should rename it to something, anything, different than what was most recently used to flash the printer. I suggest something like “sv06p_xxx.bin” where xxx is the actual fw version.