SV06 Plus Level Shifting

I have a new SV06 Plus printer that I am really enjoying so far. However, I am trying to print a collapsible master sword and am having issues. At the same layer, the print shifts slightly, ruining the print. I caught it the first time after it added just one more layer. I tried printing it again overnight, thinking it was just a leveling issue, but the same exact shift happened on the same exact layer.

I thought this time it was a problem with the GCode, but after reslicing, uploading, and double-checking the belt tensions the exact same level shift happened. This is not the first 3D print I’ve had that goes this tall, and the previous ones were fine. I did change to a larger roll of filament for this project because of its size, but I don’t think that explains the consistency of the issue.

In short, my printer keeps having a level shift at the exact same level for this project, and I have already checked the leveling and GCode, yet it has done it 3 times now. Does anyone have any ideas?

Since it shifted twice…back & to the left…and the belts are alright & the cord is not under the bed…
Try changing your infill to Gyroid, I’m thinking the nozzle hit the infill & caused this.
The nozzle can’t hit using Gyroid, that’s why most users use it…but it does come with a lot of bed movement…so you have to make sure your bed is clean or the print will come off.

Other than that, I would run the Z Adjustment…and watch it looking for a skip or something on the way up & down.

So I tried two more things. First, I tried a whole different print using the same settings as before. It was completed, getting twice the height without any issues. Second, I retried the sword with the gyroid infill as you suggested. It shifted again, this time at a lower layer. I caught it this time though, and it seems the printer keeps catching on the innermost part of the collapsible blade. I’m starting to think this was just a poorly designed STL, since I have tried everything and other prints still work.

Ok, catching on the inner most of the sward, that means that part is coming off the bed.
Try increasing the 1st layer temp by 10*, only the 1st layer…or you can try some glue (Elmer’s Purple works great).

Have you figured out what was happening yet?

As you can see that the nozzle is hitting the print and causing the shift are you using Z-Hop?