SV06 Mainboard brick after updating Sovol Firmware

Michael Hill hat für das Sovol Board ne neue Firmware erstellt.

Can somebody tell me the steps to get a mainboard reissued by the support as offered? The support normally answered daily, now they didn’t anwer for several days.

Hi @R3B0RN Sorry for the inconvenience caused. Could you message me your order id and email address? I’ll forward your info for further look ASAP. Thanks for your patience in this regard.

@sovol3d I have recently bought a SV06 from your website and I have the same problem with the blue screen. I tried every tip on this thread but nothing works for me. I also sent a mail to the customer support via but i didnt recieve any answer. Maybe the Mainboard doesnt work properly. In pronterface it gave me the same SD card error as mentionend here in the forum but recently there is nothing coming from the printer. It turns on and the display turns blue but thats all.
It so sad that it went in this state even before the first use.

Sorry for the late response. I’ll contact my colleague and he’ll get back to you and follow up on this matter via email shortly. Can you give me your order id and email address pls?

This did it for me! Ordered 'em. Got 'em. Formatted to default fat 32. Copied the .bin, inserted it, turned on the printer and in 5 seconds got the Sovol logo! Such an easy fix after hours of frustration trying to get the supplied 8 gig card to work. Thousands of thanks!

1 Like

@sovol3d I have the same issue and I am unable to fix it despite numerous attempts… I received the printer yesterday, could print a benchy, then followed the steps to update the firmware. Only blue screen lights up now.
I sent you an email with the details to along with the order number.
Let me know if any other troubleshooting steps…

I managed to fix it today. I spent a lot of time in forums, with some mentioning non sensical things like making the firmware file executable, etc.

In case this helps someone:

  • Use a small 8GB SD card
  • Format the card with FAT32 and make sure you set the sector size to 4096 bytes (or ‘4K’) (->This is critical, many cards come formatted with 512b sector size)
  • copy only one firmware (bin file) and rename it with a short simple name that was not used before for flashing.

I tried with many sd cards, formatting them from Mac os, Ubuntu and Windows without luck until I found about the sector size requirement. Then it worked right away.

1 Like