Sorry folks, just a cry for help

Received my SV-06 just three weeks ago. Worked fine when I first got it was really impressed with what it could do. However now when I switch it on the screen glows but there is no text on it. Unit is definately getting power, power supply and control board fans are spinning, Z probe LED is glowing, a blue LED is glowing inside the control board box. I have checked all cables are fully home yet this does not seem to do anything. I have written to SOVOL about this but was wondering if this was a known problem with a known solution that I could try before SOVOL gets back to me?

Take out the SD Card & turn it back on.
If it works, the SD Card is bad.

No SD card in it.
But thanks anyway

It might sound stupid but this fixed mine when I had the same issue…it only happened once.
Unplug the printer for 30 min, then plug it back in.

Have left it plugged in, left it un-plugged for various amounts of time, nothing seems to make any difference…
But thanks anyway!

YIPEE!!
Fixed it .
I had written to SOVOL about what to do before I sent it all back.
They sent me a list of troubleshooting steps. I followed this to the letter even to the extent of un-plugging EVERYTHING from the MoBo/main board, apart from power supply and screen connectors. Still no joy .
Step five(5) on their troubleshooting list was re-flash the firmware I re-flashed the firmware and all was good again.
I had to go have a cup of tea before re-connecting everything to the MoBo/mainboard again…
As my nerves were jangling.

I just wish step 1 had been check cables, step2 re-flash firmware THEN try dissconecting everything.

Thanks all for the help.

Re-flashing would have been the next step, but if your display was bad…it wouldn’t have helped.