Nozzle scrapes print on petg

I have never had this issue on any of my printers except the SV07 plus. My nozzle scrapes the print after about the third layer, it gets worse the higher it goes. I have dried my filament, tried other filament vendors and they all do it. Any idea’s on fixing this issue, it prints pla with no issues.

I normally use orca slicer but tried cura, and prusa slicer with the same results. I prefer finding a correction to the underlying cause rather than a “it just works fix”

Over extruding ? What is the flow setting on your PETG profile vs your PLA profile ?

Have you tried doing an extrusion calibration ? Something like this:

If the printer is over extruding the error will compound on every level as every layer is slightly thicker than the height that the Z axis is stepping.

Different materials extrude slightly differently, I think most people would do an extrusion calibration with PLA on the printer settings and then apply a slight correction with the flow setting in the slicer for filaments that need it like PETG.

It also depends what you’re printing. On my SV06 Plus I don’t usually have problems with nozzle scraping, however on 0.1mm layers when printing infill there is sometimes a slight scraping noise.

What layer height are you using and what is printing when it starts scraping - infill or a flat surface ?

I ran the flow test in orca slicer, flow is .93’ish. I’m beginning to think this issue has multiple parts to it. I checked the gap between the bed and the print nozzle. At 200 microns (.2) I’m getting 310 microns (.31) I used a set of certified father gages from work, I’m going to get anal her today and set the gap with a cnc tool setter :slight_smile:

Printed a layer test .20 thick after setting bed zero to “0”. Measured layer times with calipers, bingo! Layer is between .19 and .21… not too bad. Interesting though, the bed moved quite a bit the hotter it gets, at 90c all the numbers literally shifted around the bed like a clock moving counter clockwise, lowest number is now .20 and the largest is .22…

Yes, thermal expansion of the bed at different temperatures is enough to throw out the first layer height.

The built in calibration routine heats the bed to 60C, so if you print at 90C bed the gap would be slightly different, however the Z-axis homing that is performed at the start of the print is done after the bed is up to temperature so this should be accounted for - at least in the centre of the bed.

If you did most of your printing at 90C you would probably want to do the mesh bed levelling at 90C as well, as the expansion between 60 and 90C may not be even across the bed - there is no way to do that in the touch screen interface but it can be done via issuing G codes over the USB port. (For example using Octoprint)

In my experience I’ve found the Z-axis offset adjustment (and by extension the mesh bed levelling) THE most critical thing to get right to prevent prints failing.

It needs to be correct within +/- 0.05mm. Even 0.1mm out in either direction will cause obvious problems with the way the first layer is applied.

Too high and you won’t get good layer adhesion causing the print to lift as it prints, (sometimes even parts of the first layer won’t stick) and too low will cause a lumpy/bubbling first layer with visible signs of the nozzle tip scraping the surface.

I usually start with the paper test (standard A4 paper is about 0.1mm not 0.2mm as the calibration sheet suggests!) to get it close and then do a number of small prints that are flat and just a few layers high and watch as the first layer goes down to see if it lays smooth and flat or starts bubbling or scraping, then adjust in 0.05mm steps until it’s printing right.

I print this little thing that I designed for doing this first layer calibration:

It also has a couple of small towers and bridges to help check stringing, part cooling and bridging performance, and only takes about 4g of material and 15 minutes to print.

Measuring the gap with paper or feelers is difficult because there is usually a tiny blob of filament stuck to the tip of the nozzle if you have printed recently, this is enough to make the gap seem smaller than it really is unless you make sure you clean it away, and also remove the filament so more doesn’t ooze out during the calibration process.

So I do the fine adjustment based on first layer print quality rather than trying to do a super accurate measurement of the gap.

I use a macro that reads the print temp and looks for creates a mesh for that temp… it’s handy :slight_smile:

I’ve recently upgraded my SV06+ with the Sovol Klipper kit so it now functions very similarly to the SV07.

I’ve done something very similar by adding a single line to my Cura start G-code:

BED_MESH_PROFILE LOAD={material_bed_temperature_layer_0}C

I have multiple bed mesh profiles created at 60C, 70C, 80C, 90C and 100C:

When I print it automatically selects the bed mesh for temperature selected in the slicer. It only works with these specific temperatures but that’s good enough for me.

And yes, there is quite a difference between the bed meshes at different temperatures, especially at 100C, which I use for printing ASA:

When I was running Marlin I only had the one bed mesh done at 60C - that would be a significant error when the bed was at 100C to print ASA, enough to affect first layer adhesion on a large print. I haven’t tried any large ASA prints since I started using Klipper, I’m curious to see what difference the 100C bed mesh will make.