Has anyone successfully edited touchscreen firmware on SV04? Need it for printing up to 300C

I’m thinking of printing in various nylons. So I’ve replaced the heatbreaks in my SV04 with bi-metal ones, replaced the nozzles with tungsten carbide (got both from Sovol). I’ve downloaded the printer firmware source code and changed MAXTEMP to 315C (so I can print up to 300C). Calibrated everything with PLA+, it seems to work fine (I had to up the temperature 5-7C for different brands of PLA+, since the heat properties of the bimetal heatbreak and tungsten carbide nozzles are different), although I get somewhat different results each time I run esteps calibration at 220C. Not sure if it’s a normal behavior, since I haven’t run it with the old heatbreaks and nozzles. However, the printing results are fine, so it doesn’t bother me enough to investigate more.

Now, the only issue I have left is changing the touchscreen firmware to reflect the change to 300C maxtemp, as discussed in this thread: Built new version for 300 deg ut still just 260 deg - #7 by Pukin_Dog. I downloaded the source code for it from Brandon Phillips, downloaded DGUS tool. However, when I try to open the DWprj.hmi file with DGUS, I get some error in Chinese. I don’t speak Chinese. Has anyone encountered this issue, and if so - how did you work around it? Alternatively, if anyone has changed the screens 16 and 17 to 300C (and others if needed, I’ve only identified those 2 so far), can you send me those? I don’t mind keeping all the firmware stock, I just need to change it to be able to handle up to 300C.

The display firmware has to match with the Marlin firmware version. Which Marlin FW version did you use as start point for your modifications?

I used the source code for the latest Sovol/Marlin SV04 firmware, 1.1.0, got it from here: Firmware Download | Sovol3d

OK - I’ll try to build a matching display FW version for 300°C & find a way to upload here.

Thank you VERY much! That will solve my issue very well. I’ll still try to figure out why DGUS doesn’t work with it, for my own curiosity. Besides, I might have to do something like this again in the future.


The upload feature works. Not sure if it changes the uploaded files though, will test in a minute.

The file changed, no good. I can create some cloud drive account or something like Sync.com would work for a zip archive though.

I modified the touchscreen firmware & verified that it is working on my SV04.
It is stored in the zip-file “SV04-Touchscreen v1.1.0 - Sizzling Version (21Jan2023).zip”. The DGUS sources are included, too.

This forum won’t let me upload zip-files, therefore I uploaded it here: https://ufile.io/pl5u850m

Unzip, follow instructions & use it at your own risk.

1 Like

Thank you! I downloaded it and will go through and flash it tonight, and let you know how it works.

P.S.: went over the screens, everything seems to be there. On to flashing :slight_smile:

Finally got around to flashing it. The first few attempts didn’t work, for some reason the printer doesn’t even pick it up. I formatted an 8GB SD card (and it works with the printer), copied the DWIN_SET folder on it, but when I try to boot from it, nothing happens, the printer just loads normally. I’ll try to flash it with the original firmware to see if this is something related to the new firmware, or some other issues (card, printer, etc.).

Did you use the card in the microSD slot of the DWIN display?

Well… do I feel stupid now. I didn’t even know there was such a slot :slight_smile:

Thank you, I’ll try that :slight_smile:

There is a document included in the zip archive “How to flash the TouchScreen firmware on SV04.docx” that explains the process. You need to remove the display bottom cover iot access the microSD card slot.

Oh, I read it. It just didn’t click that the touchscreen has its own microSD card slot for this. Live and learn :slight_smile:

Finally got around to flashing it, life got in the way. It flashed fine, it works. I tried to run it up to 300C, got the thermistor error at 293C, but that’s a thermistor issue (might look into better ones down the road). The sound got lost (you know, the beeping sound when you touch a button), but that’s not much of a loss. Running the test print now (at 220C, gotta buy nylon first), since I’ve changed a few other things too.

Thank you very much, Bjoern! I’ve noticed you helping the people here a lot. People like you make life better.

Hi akholic,
thanks for your feed-back. The touch button sound was not part of my quick test.

hope you get it to work. I didn’t and just bought a new motherboard and made new cables instead of the flat ones to the gantry. Some work with that, I can assure you. :frowning:
One reason to go this route was to be able to use high temp thermistor like PT1000.
Did you get it over 300 C with stock sensor? I read that there where some issue with it.
/Pukin Dog

I didn’t get it over 300C, it errors out at a bit over 290C. I haven’t looked into a different thermistor yet, as 280-290 should be sufficient for my purposes. Maybe, even 270C. If not - I’ll have to deal with it. Speaking of which, shouldn’t an SV06 hotend and thermistor work?

Ok, that’s a bummer.
I think it’s quite bad that Sovol sell full metal stuff for it but they will not allow temperatures that make it usable. I guess there are some blends with carbon that doesn’t need high temp but it is frustrating.
I haven’t a clue if that fits but I can’t either see why not.
Good luck to you!

I don’t see any reason to blame Sovol for that. The SV04 printer is specified for max. 260°C temperature. Reaching higher temperatures in a reliable way will for sure require more than just altering the software: Changing of heat block, thermistor, heatbreak & insulation/cabling. Btw, the firmware settings have to match the new thermistor & heater type.

1 Like