Built new version for 300 deg ut still just 260 deg

I feel a litle cheated here. I built a Marlin version based on their latest firmware. Changed it to 310 degr for E0 uploaded it and it gave ok on the upload.
But still I can only go to 260 dgr and it seems to me that the darn screen has software that prevents higher value. What kind of garbage is that.
How can one get around this?


Many printers are sealed at 260°C so that the PFTE does not decompose. At temperatures above 260°C, PFTE decomposes with highly toxic gases that are said to even kill pets.

Yes, I know that. That’s why I’m using full metal heatbreak in it… The fact that they are selling that heatbreak but still not be able to go higher than 260 is not logical. There is no need what so ever for it as it is now.

If the firmware doesn’t limit it, then it’s the cartridge heater.

I use a 24V 50W cartridge heater on the Weedo X40 and get up to 350°C.

I have tried to change the fw but it is the screen that block a higher value. That source code is not available so no go there. That is why it sucks. A printer 2022 should not be blocked like that since a lot of material need a higher temperature. If I had known it, I would never have bought it. But it is what it is and I will change the motherboard and display.

Hi there,
you already found the maximum temperature limit 260°C setting in the Configuration.h file in line 563ff:
#define HEATER_0_MAXTEMP 275
#define HEATER_1_MAXTEMP 275
#define HEATER_2_MAXTEMP 275
#define HEATER_3_MAXTEMP 275
#define HEATER_4_MAXTEMP 275
#define HEATER_5_MAXTEMP 275
#define HEATER_6_MAXTEMP 275
#define HEATER_7_MAXTEMP 275
#define HOTEND_OVERSHOOT 15 // (°C) Forbid temperatures over MAXTEMP - OVERSHOOT

The touchscreen maximum input limits can be altered using the DGUS tool: The settings are located in screen 16 and 17.
Touchscreen sources could be found here, but there are several modifications inside that need to be undone iot match the original SV04 firmware:
Alternatively, you could retrieve the sources from the SV04 touchscreen firmware as demonstrated in this YT video:

Anyhow, be sure to know what you are doing before altering the settings here & recompiling the firmware - it might be a sizzling experience…


The settings in Marlin is no problem. I was stuck with the darn screen. I don’t know what to make undone to match the original so I guess that using that tool to get read the fw that is there is the way to go here.
I didn’t know that was possible.
I do have an Octopus main board and a new screen ordered to do it myself so if it goes south I do have the same rout I intended to take as an option.
Thanks for this info, it will be fun… Or not…

Sincerely Yours

Hi Johan,
it is not difficult to undo - all removed files are available in the commit for download here:

Meanwhile I installed & tested Brandon Phillips’ SV04 firmware V1.1.B3.3 & the matching touchscreen firmware V2.0.B3 Release V2.0.B3 · bphillips09/SV04-Touchscreen · GitHub on my SV04:
It works fine & I like the new features (SD-card subdirectories + auto-tramming + finer hotend offsets). Maybe you want to restart your modification from that point. You need to install that DGUS tool from DWIN. On my linux desktop the temperature control screen (16) looks like this:

Just enter the new limits, save, export, & copy the DWIN directory structure to a fat32 formatted micro-SD card & reflash the touchdisplay firmware,

Greeting from Germany

Ok, I’ll go with the same then but change the max temp.
Hope I don’t screw it up. :slight_smile: Thanks

I did this several times but I only get checjsum 0 on every line. It shouldn’t be that I suppose. The only thing I changed in Screen was maxtemp on extr 1 and 2 then in order you wrote. Save-export-copy folder dwin to card and start.
In the marlin file I changed maxtemp on extr 1 and 2 to the same value. That one worked fine to flash.
It’s the screen that is the problem here.

I’m not an expert in using DGUS - maybe you need to rebuild the icl files & store them in the DWIN folder, too.


They are in the same folder together with a lot of other files.
It’s weird.

I now tried with the DWIN.zip file on the same site and that also gave 000 in file check so there is something elsr going on here. That on should have worked since it was precompiled.

Hi again Johan,
did you use a properly formatted MicroSD-Card (max. 16 GByte, FAT32, sector size 4096) for reflashing your touchdisplay?
According to that site this might be the problem:

I managed to get several modifications running on my customized touchdisplay screens.

The DGUS II Application Development Guide is also very helpful - it is availble for download on the DWIN homepage, too.


That was an interesting find. My card i larger than that so I have not been able to follow that. I did not find that in my searches either.