Extruder motor not working after bltouch and firmware update

Hi all. I just got my BL touch sensor working properly after having a heck of a time because of wire colours and orientation. Everything works fine except it won’t activate the extruder. If you preheat the extruder, select that axis from the touch panel and then try to move the extruder it doesn’t do anything. I thought maybe during the bl touch install I damaged the ribbon cable for the extruder motor. If I connect the extruder cable to the z axis port on mainboard the extruder will turn so that rules that out . Does anybody have an idea why it might be dead? also I installed the latest firmware from CopterTec


Hello Horsen
Could you please tell me which machine you are using?
Thank you
Best regards
Sovol Team

I’m using the SV01.
I also tried reflashing to the firmware on Sovol website and it didn’t help.

Hi Horsen

Do you have a multimeter to check if you have current coming in the cable?

I plugged the extruder motor and cable into the z axis driver port and the extruder motor worked fine with z axis controlling it so I know for sure that the wire and motor are not the issue.

All this mean is that the cable is good, but one of the thing that I’m worried about is , Are you getting current from this port from the motherboard?
Also, have you tried to connect your printer to your computer through USB and use Pronterface on your computer to enter one line of Gcode to request for extrusion?
Also, what changes have you done to the firmware to add this BL Touch device? Can you list the changes?
Sorry for these questions, I’m just trying to understand what could cause this.

I understand now. No I didn’t test to see if there was current, I assumed that there was none as the motor and cable work on the z axis. I didn’t use Pronterface, I don’t even know what that is, to be honest I have zero experience with computer coding. I followed the video’s from Joshua Bardwell and Aurora tech with both versions of the firmware.

I added the G29 L0 and G29 J to the slicer start gcode.
one thing I just thought of is all of the videos I’ve watched, they all use Cura whereas I used Prusa slicer to load the firmware. That couldn’t be the issue, could it? I’m just grasping at straws at this point looking for things I did differently.
Thanks for your help Ciol

Hello Horsen.
Is the BL firmware you brushed the firmware from the sovol website?
If other firmware is used, there is no guarantee of aftermarket parts.
If you are using the firmware provided by sovol, you can contact our after-sales service for assistance.
Sovol official website: info@sovol3d.com
US Amazon:amazonus@sovol3d.com
Euro Amazon:sovol_3d@outlook.com
Ebay: sovol-uk@outlook.com
Thank you
Best regards
Sovol Team