Please help z axis i will pay!

ok so if someone can help i am happy to pay…sv03 it worked fine and has only been used a few times and worked great . then i stopped a print but never aborted it and shut printer off …now it acts funny …x and y auto home , z just flashes with ?? on lcd , if i go to level corners it says homing xyz on lcd and just stays like that until i power it off. the z axis stays about 9 inches up and does not lower , the bl touch sensor blinks always , probe test does not work …i have tried a bunch of gcode commands on cura and nothing …i am not good at thi and have been trying so hard but at this point if someone can help i would appreciate it or i will have to sell it …thank you lenny … you can text me incase i dont receive msg from the forum because i just signed up 272 788 1429

Hi. Could you check it by following steps.
First, can the probe be retracted twice normally when the printer is just turned on? Re-plug the probe end of 3d-touch, and wiring between the adapter board end and the main board end to ensure that they are firmly inserted and not damaged.
Then, check whether screw on the top of the 3d-touch is tightened?
And also you can try to flash the firmware again.

Firmware: SV03_Marlin2.0.x_BL_V1.0.hex - Google Drive
Reference tutorial: How to Install Touch Screen on Sovol SV01& Sovol SV03 and Flash Firmware - YouTube (from 2:50).

Tell me if it still doesn’t work.

That firmware you shared …can I just send it straight to the svol sv03 …or do I have to do the whole configuration.h thing…it’s tough because where my printer is I don’t have wifi…do I try to download everything at work on my laptop …but I am really not good at this stuff…my prints were finally coming out great …basically this all started when I stopped or paused a print …but did not completely abort then I shut printer off …ever since then it has so many weird things going on and it also functions better when I unplug the one plug to the right of the bltouch sensor ??? Not sure what that is but if I unplug it the bltouch still works and it will level corners instead of just pausing on “homing xyz” and never moving to a corner

Sorry for causing you trouble. But I was wondering if you can post some pic of that or video? We can figure out the problem then.
For firmware, you may have to download into your laptop at first. Sorry if that trouble you, but please try it. If you have question during the process, please post here, or you can also pm sovol page in FaceBook, or even send email to