Bed will not level

When I try to level the bed it will move to the left, the bed will go back, then the hot end will raise a small amount and vibrate and say it is complete and store the settings. When you start the screen will say 1 of 25.

Have you reset the EEPROM ?

Unfortunately I am computer illiterate . I have updated to the latest update and I tried restore defaults. It would do it occasionally but start working if I kept running level bed. It has not worked. Thanks for any help that you can give.

Why did you update the firmware ?
If you have bought it recently, normally the printer come with the last release.
What is the release of your firmware ? I know there is a 1.1.5 release but, on the sovol web site, just the 1.1.4 is avalaible.
Maybe your update went wrong. Do it again.

23-feb-2023 is the update I installed

So, try to reinstall it.

made no difference . I can make a video on my phone but I don’t know how to download it. I could send it in a message on the phone if you don’t mind giving me your number… If a video would help.

Not sure I can help you.
Make a video and post it directly from your phone

Post in online…Google Photos, Google Drive, Dropbox…etc.

Ok thanks for your help.


You have the video locked with your account, I can’t watch or download.

try it now. I changed to anyone.

Since it does it when the Z raises…try doing a Z Alignment.

already tried it. no difference.

yeah, I don’t understand as the z rises instead of going down like it is supposed to. If I keep running the leveling program it will go all the way to the top.

From your video, it sounds like the stepper grinds when the Z Axis rises.
This is why I wanted you to do a Z-Alignment to see if the gantry raises all the to the top & back down or if it just raises a little & stops.


Video is locked again.

Sorry, try again. I guess I have to unlock each one.