SV06 Plus klipper screen reflash/update for crowsnest

Apologies in advance, Klipper/Linux noob here…

I was trying to set up a webcam to my SV06 plus klipper screen and it was recognized in the crowsnest log file, but it failed to start the stream.

I followed some guide on updating crowsnest via SSH and it wasn’t working, so I uninstalled crowsnest and tried to reinstall it but now I keep getting an error that Debian 10 isn’t supported by crowsnest and it won’t install.

I can still print but I’m wondering if I can reflash the klipper screen back to stock to try to get crowsnest back, or a more update version of klipper that supports crowsnest. I think sovol has downloads for reflashing the SV07 klipper screen but I don’t know if that would work for the similar SV06 plus klipper screen I have.

Also if you could link me to any guides on how this SSH/Klipper/Linux stuff to help me have a better understanding I would appreciate it :grin:, I know just enough to be dangerous lol

Thanks

Okay after watching some videos to better understand the command terminology and what the guides i was following were asking me to do, along with understanding the errors i was getting

The latest Crowsnest wouldn’t install because of a recent compatibility problem with debian 10 buster (MKS armbian operating system?).
I had found a legacy version of crowsnest and tried to install, but then also got an error something along the lines of “crowsnest already exists and is not an empty directory”
Also in my earlier attempts to install, I may have been impatient and unfamiliar with what the installation process looks like when it was done, and rebooted the system prematurely thinking it was done…
I removed the diectory with “rm -r crowsnest” and then retried installing the legacy version 3 from github with patience, and success!
Crowsnest is back and video works now!
I’m guessing something about ustreamer got fixed when did all that.

So I didn’t need to flash an original image to my SV06 plus klipper screen after all to get crowsnest back.
Though out of curiosity I did open up my klipper screen to see what board it was inside, and it said MKS KLIPAD 50
Definitely not an off the shelf MKS Pi, and in my printers info section it says “host version 1.0.0-06P” and SV07 plus firmware looks like 1.0.8-07P so im going to guess that they aren’t compatible, not that I need to re-image now.

thanks for coming to see my stumbling through this problem :sweat_smile:
Cheers!

I would also like to start all over - do you know how to factory reset the klipper screen as you wrote something like reflash the screen?