Klipper screen stuck in loop (SV06 Plus)

I installed my klipper screen on my sv06 plus and had it working fine, all of a sudden after turning the printer back on the screen is stuck in this startup loop, and all the files from the flash drive are gone! I have no clue what to do. Sovol has not responded and i am not able to find any info on how to fix it! can someone help me please!!!

Good morning
I have problems too, random errors, blocking. Operation under Klipper is not explicit enough, I reverted to the original Marlin firmware for the moment where I have no problems. I sent a message to Sovol, but no response yet

Same with the Klipper Screen on SV06 Plus, after shutting down or restarting the printer, printing is not possible: Error “Save_last_File”. After manually deleting the file list, everything works fine until the next restart/shut down.

Is there a way to factory-reset the klipper screen?

Newb here, but it worked for me.

Download the firmware and follow the instructions provided in the zip file

[Sovol Klipper Screen]

scroll down and you will see the firmware, which is posted on Google docs.
[SV06 Plus Klipper Screen Firmware - Google Drive]

BTW, I tried numerous times to update the firmware using the right USB port on the Klipper screen, just for the heck of it, I unplugged the USB that goes from the klipper screen to the control module on the Soval 6 +, and it worked.
Not sure if I missed that in the instructions somewhere or what. Good luck