SV04 Turbine on print head 2 not turning on

Hello,

Just got an SV04. The turbine fan on the front of print head 2 has never turned on.

I’ve updated to the latest firmware for the main control board (1.1.0) and still nothing.

  • Using my bench-top power inverter I directly supplied the turbine motor with the DC voltage listed on the motor label and it ran just fine.
  • I checked the small board mounted to the back of print head #2 for continuity to the ribbon cable and continuity was good.
  • I haven’t yet tested the ribbon cable for continuity or breaks, but it looks fine and since the wires are in the middle of the cable, I don’t see how they could be faulty.

The turbine for print head 1 works fine so this issue is not affecting both motors. It seems that 24V just isn’t getting to the turbine of print head 2.

I’m suspecting that the main control board just has a bad circuit and needs to be replaced. Does anyone know who to contact for a warranty replacement on the main control board? I would hate to send the entire unit back for just a small, easy to replace board when I can just swap out the part in 15 minutes.

Hello Brokenfanman
Really sorry for the late reply.
Sovol official website: info@sovol3d.com
aliexpress:3020058294@qq.com
US Amazon:amazonus@sovol3d.com
Euro Amazon:sovol_3d@outlook.com
Ebay: sovol-uk@outlook.com
You can contact the platform of customer service that you bought.
Thank you
Best regards
Sovol Team

Hello,
1、The turbo fan will only rotate when the model is really printed.
2, you can control the turbo fan rotation in the interface of the heating nozzle 2 (as shown).
3, on the adapter board and another fan exchange test.
a, after the exchange can turn, may be other accessories damage caused by not turning.
b, after the exchange does not turn, is the fan problem.
4, the probability of fan damage, it is still recommended to test.

Yes. I tested the fan with this screen. Blower fan 1 works. Blower fan 2 does not work.
As stated in my original post I tested if blower fan 2 is ok by supplying DC power to it directly and it runs fine. The fan is not damaged.
Also, I tested the continuity of the adapter board (the board behind Nozzle 2) and it was good. This is acting like a broken main control board. It seems to not be sending the 24V that the fan needs to run.
I checked those pins and it does not send current when the fan button you show for Nozzle 2 is on.

Hello,
You need to contact our customer service, they will reissue a new fan to you.
Sovol official website: info@sovol3d.com
aliexpress:3020058294@qq.com
US Amazon:amazonus@sovol3d.com
Euro Amazon:sovol_3d@outlook.com
Ebay: sovol-uk@outlook.com
Thank you
Best regards
Sovol Team