SV04 is reading G-codes backwards

Hello, I’ve had my SV04 printer for about 4 months now, which printed perfectly all this time, however it suddenly started doing something very weird. It now reads any Z axis changes in the G-codes in reverse, meaning a line telling it to move up will make it move down (such as Z hopping on retract will make it move down to hop). This behavior just suddenly happened half way through a print, a print that was started fine.

If I tell it manually to move up, it does. When it auto-levels the bed, it will move as expected, up a tad then down to probe. It’s only when it is actually printing from a file that it reverses the Z axis.The X and Y axis both move as normal, so it’s only the Z. It’s also not due to a change in slicer, as Gcode files I’ve printed before now won’t work.

I’ve tried reflashing the firmware, I tried adding M92 Z400 to the start Gcode, but nothing fixes this problem. Has anyone experienced this, or even heard of it? I’ve been printing for about 4 years now and this is the first I’ve even heard of one axis working perfectly fine except when it’s reading instructions.

Hi, Rein. Please make sure you reflash the latest firmware :point_right: SV04 V1.1.0 (24th Jan 2022) - Google Drive

I did reflash it, multiple times. I even renamed the machine in the firmware just to be sure the flashing went through. I also tried flashing the unmodified firmware you linked.

Rein, I thought my Amazon team colleagues received your email. They were helping you. :wink: Feel free to contact me if there is any question

I thought so too, but I haven’t heard anything from them :slightly_frowning_face: . Any info on if they are still trying to figure out a fix?


Could you please check if it is thought of as spam in your email?

yes I checked my spam folder, I’ve also used the search to see if it’s in any other location. The last email was them asking me for my order number, which I replied with.

Could you look for this email If you cannot find it, could you please send the info to this email one more time?
Sorry that this causes you trouble.


I also have the latest firmware v1.1.0 and I’ve encountered a similar issue but where the Y axis moves in the wrong direction at the end of the print. The G-code clearly indicates the bed should move to the front:

G1 Y302 ; Present print

But instead moves to the back.

In the Move screen, if I enter Y position 302, the bed indeed moves to the front as expected.

The only other similar occurrence of this that I could find was this post on StackExchange: