Sovol SV02 screen stuck on booting

Tried all screen firmware flashes from all available firmware’s. USB connect to laptop not detecting printer to update mainboard firmware. Barely used the printer, color mix extruder on hand. Gonna try to install new extruder as a potential fix, maybe thermistor causing a short.

Hello Datalord.

  1. check whether the device manager has a port after the computer is connected to the motherboard; if not, please replace a usb cable or try to insert a different port.
  2. If there is, but can not connect to the slicing program, please update the driver, you can refer to:
  3. it is recommended to use prusa to update the firmware, cura reading speed is slower.
  4. screen start loading stuck can be solved by re-flashing the motherboard firmware and screen firmware, download site: Firmware Download | Sovol3d, please choose to download the firmware according to their own machine has no mixed color nozzle and bltouch, the motherboard firmware and screen firmware should match, otherwise it will cause the boot
  5. thermistor short circuit will cause heating failure, but and can not connect to the computer and can not start should not be related
    Thank you