Sovol Klipper Display MCU Error driving me crazy

Hello all,

today i tried to convert my SV06 Plus to Klipper using the genuine Sovol Klipper Display.
But i keep getting the MCU error message.

Did anyone of you also had this problem?
When it works its very nice but this error kept me from printing. I was not able to finish one single thing and also had this message very often during setup.

Kind regards

Good morning,

i would not say that i found the problem but after i connected the Mainboard an the Screen via USB 3.0 Port the printer works. For the Moment… We will see.

I got mine today and have the exact same problem - I ran the input shaping calibration and it shut down randomly, sometimes justafter a few seconds and sometimes after a minute or two…
Also, when starting to heat up bed - same thing, disconnect…
Not been successful in doing anything with the new klipper screen so I’ve contacted support for advice.
I suspect PSU to be crap but Ill try the USB as suggested in the thread

first i also thought that the PSU is the problem but it seems to be just fine.
Please try and report with the other USB port.

Other little problem with the Klipper screen are the endstops.
X and Y axis hit the end but don´t stop the motors in time. So that the motors try for some seconds to turn the axis further.

I also now got rid of the endstop problem.
What worked was adjusting the senitivity:

[tmc2209 stepper_x]
diag_pin: ^PA1      # Set to MCU pin connected to TMC DIAG pin
driver_SGTHRS: 255  # 255 is most sensitive value, 0 is least sensitive

I added 10 points on each axis nad now it works just fine.

I’m facing the same issue. :frowning: I’m going to reach out to Sovol support about this as I don’t understand why this is happening.

I’m having exactly the same problem, messaged Sovol for help and all they were interested in was my receipt, it’s been a week since I sent them my receipt and they still haven’t gotten back to me, what am I (or any of you) supposed to do with my 3d printer that won’t print, installing the klipper screen has turned my printer into a paperweight.

I had the exact problem. Supplied usb cable would disconnect after any stepper motor movement. Another cable worked slightly better, but the screen is still useless with ghost touches and it won’t control the motors properly.

Sovol, we need answers.

I had exactly the same problem, mcu crashing very often.
Most often when heating the nozzle and the bed.
The cable sent by Sovol after-sales service did not change anything.
I thought it was a power supply related problem.
So I removed the 500w power supply of my sv06 plus and put a 350w Meanwell power supply i had in stock.
Since everything works perfectly, no more MCU crash problems.

Did you try to update the screen? This is the only time I had this. I would go to their product page and get the screen software and reflash. To do so, toss it on the drive they give you and plug in while the screen is on still. It should read it and flash. Takes about 2 mins or less.

Did you ever figure this out? Just got mine, same issues. It’s driving me nuts!

This is most likely due to a bad or underperforming USB cable. I had the same issue, and was told by Sovol support they would ship a replacement cable that included a magnetic ring to prevent interference. While I was waiting for it to arrive, i swapped the cable with one I had from my Mintion Beagle Cam. I haven’t had a problem since. Incidentally, the replacement cable I was sent also did not work, so I stuck with the one from the Mintion.

Ok. I had this same problem, and I did some investigating. My Father and I determined that it was something wrong with our motherboard. We had already tried replacing the cable to no avail. I thought that maybe the motherboard wasn’t getting enough power, so I plugged in the old screen, unplugged the new screen power from the power supply, and found that the old screen did nothing. I took the original Sovol sv06+ firmware from the website, and unplugged the MicroUSB cable and re-Flashed the original firmware. Then the old screen worked. So then I plugged in the new screen and saw that the old screen still worked (I had not plugged in the USB cable yet). Then I took the firmware on the flash drive included, and, with the usb still unplugged in both locations, reflashed the firmware. I watched the blinking blue light on the motherboard until it stoped blinking to signify that the firmware was flashed. Then I unplugged the old screen, and plugged in the new screen USB, and it worked.

TLDR: Unplug new screen USB from both locations, flash the normal firmware, then flash the included firmware, then plug the new screen back in.

Be sure to wait until the firmware is fully installed by watching the small blinking blue LED near where the miniSD card is located.

I hope this helps others, this worked for me.

1 Like