Printrer won't home

My printer won’t home and the x-axis hugs the left gantry support for 10 seconds, vibrating badly. I’ve tried changing the homing values from standard 65 units, all the way to 100 with no effect. The strange thing is, the printer printed 3 objects the day before with no problems, then the next day, just turning it on made it fail to home. I’ve watched YouTube videos, read a number of posts, tried everything…still have a problem. Comes at a time when I had a really big print job. Now I’ll have to use my Dremel 3D45 which is not as convenient or capable (hence the reason I bought another printer!)

I solved the problem. Easy once you know what to do… From the main settings menu on the printer, I Reset the EEPROM. I was afraid at first that it would be horribly out of commission doing so, but I was desperate. I did this, then pressed the alignment button which started the PROPER process of homing. I recalibrated the nozzle offset and am now happily printing. So. FIXED.