Pause at Layer Height Mutiny

Context: Sovol SV04 printer

I am trying to embed a magnet in a 3d print,

So logically, I use the “pause at print height” (pause at layer height specifically)

I run the print, (this is the mutiny part) it pauses, I embed the magnets, then NOTHING. I don’t have an option to resume print. (after reading thru forums) I decide to turn of the printer, and as it restarts it resumes the print, yet it starts printing 5 mm above the print. Basically, its just extruding on thin air above the print (guessing during the shut down the steppers lost their position)

I then immerse myself in forums learning g code, and searching for a solution.

I found a post from Greg Valiant (this guys a god) mentioning a glitch where certain circuit boards don’t read the following commands; M117, M1, and M0. The best way to test this is add a M117 command to the gcode and see what happens.

So I did the M117, and nothing, it didn’t read the command. I’m guessing I have one of those glitchy boards.

I done my due diligence and tried other potential fixes.

Using other Gcode commands, and combinations of Gcode.

M0

M25

M226(RepRap)

M601(RepRap)

Even trying the change filament command. Redo Layer, and Don’t Redo layer. Stepper times.

Yet nothing, they all fail to effectively pause.

I am at a loss. Does anyone have any advice on how to do this?

I have read some people will create their own custom stop print Gcode, and start print gcode. They will take the gcode, and split it at the desired layer into 2 separate g codes. So that the print will “finish” at a certain layer, you embed your magnets and then you just start “another” print, at a specified z elevation. Which effectively will “pause” a print to embed magnets, then “resume” it? Does anyone know how to do this? Would this disable the steppers in between prints?

Or any other ideas on how to fix this?

1 Like