Not saving of values, Z-Offset

Hello to the community,

i have a new printer SV04. Flashed to firmware v1.14 from Bjoern (Bjoerns firmware and screenware too. :slight_smile:

So the problem is that i adjust the z-offset, click “save” and the make the bed leeveling with 64 points. But after power of and on the values are not saved. the values are empty…

Is this normal? should i do the leveling before every print?

And the second point is that when i click initalize eprom settings an old or other z-offset is written in the display. I thought if i click “save” the values will write down to the eprom?

And the third point is, that in the info screen (firmware numbers…) under Maschine is written “creality …” and not SV04?
Is this a failure from bjoerns software?

Summarized: values i have changed will not saved really in the printer… or i make something wrong… :frowning:

and if all this works, is the step below neccessray:

Now, include in your slicer this gCode at the begging and delete all the G28 lines because this disable the mesh leveling:
M413 S0 ;disable Marlin power off resume
M420 S1 ;load mesh leveling
G34 T0.01 ;level Z bridge with a precision of 0.01mm

Best regards

Hello Alexander,
bed levelling usually needs to be done once after changing firmware, resetting EEPROM or changing the printbed. Pushing the “Save”-button after bed levelling has finished will save the measured mesh.
Initializing (=resetting) the EEPROM will recover all offsets that are hardcoded in the Marlin firmware - in that case the settings for my SV04. Therefore you may want to write down your offsets before initiating a sequence of M502 “Reset” and M500 “Save” as all offsets & the mesh will be lost afterwards. And yes - you’ll have to run & save the 64-point auto mesh levelling once again…

The Machine Type displayed in the info-screen should be “Sovol SV04”. I assume that the firmware & the display software installed on your SV04 do not match. I would recommend to download & re-install both again.

There is no need to avoid G28 - I built the my firmware version with the RESTORE_LEVELING_AFTER_G28 option enabled. It will restore the prior leveling state immediately after executing G28.

The following commands are part of my slicer startcode sequence in all modes - they proved to work :

G28 X ; Home all "untrusted" axes
M420 L0 S1 Z2; Load the bed mesh

Good luck & best regards

Hello Björn,

many thanks for the answer. This helps to understand… :slight_smile:

So i will use the code from you below in my slicer. I hope i know where i have to put it in… I will find it. :wink:

Hello Alexander,
that two lines g-code above are just a part of my startcodes for homing & setting up the mesh. The complete startcodes contain more instructions & depend on each mode. If it helps I could upload my PrusaSlicer configuration here.

Hello Björn,

i see you are german too… :wink: But i think we can go on with english for the other people.

So if you want you can upload here your PrusaSlicer configuration. I worked up to now with cura, but not tried the SV04 with PrusaSlicer…

Hallo Alexander,
der interessierte Leser wird wohl einen Übersetzer bedienen können…
Anbei meine gesammelten Einstellungen für den PrusaSlicer v2.7.2.
Der Import geht wie folgt:
Datei > Import > Importiere Konfigurationssammlung… & Auswahl der beigefügten ini-Datei
PrusaSlicer_config_bundle.ini (74,3 KB)


Hallo Björn,

besten Dank für deine Settings… Hab sie mal rein geladen. :slight_smile:

Ein was ist mir aufgefallen: Wähle ich “deinen” Drucker aus, dann macht er beim eigentlichen Teil bei jedem Schichtwechsel ein Filamentwechsel.

Bei dem von Prusa hinterlegten Drucker SV04 Dual-Mode macht er das nicht:

Ich wollte ja gern deine Settings verwenden wegen dem “load Bed mesh”…

Woran kann dieser abwechselnde Filamentwechsel liegen? In dem benutzerdefinierten G-Code steht ja dazu eigentlich nix drin.

Hallo Alexander,
da war ich etwas zu nachlässig beim Aufräumen…
Mein letzter Ausdruck im Dual-Mode war ein Farbmix, der je Schicht die Farbe wechselte. Diese Einstellung ist bei den Druckereinstellungen im benutzerdefinierten G-Code im Feld “G-Code am Schichtende” zu finden. Einfach den Text dort mittels Semikolon “;” am Zeilenanfang auskommentieren bzw. komplett löschen.

Sorry für die Konfusion


hat funktioniert… :slight_smile: