Extrusion confused in Cura 5.4

Something stupid.
In dual mode printing I defined the extruder #1 (left) to use the PLA+ and the #2 right to use the PVA (supports). When I try to print the calibration part i select which will be in #1 with its own temperature, and what parts in #2 with its own temperature.
After slide I checked that Cura prints every part right in the preview.

And I go to the printer and … the right is now the left and the left is now the right. Looking in the gcode I can see at the beginning that activate the T1 (extruder 2) with the temp of the other extruder, and same with T0. And printing are mixed.

Has anybody printed with this version of Cura? I don’t know if its a bug or its a common error.

I seem to have the same problem.
I added a T0 at the start of the g-code, but with this, the printer uses only the left extruder.

You must replaace all To by T1 and all T1 by T0.
It’s a crazy.
I reported to Cura but they say that it’s an error of Sovol, so I’m using Cura 4.3.1 with the profiles in the Sovol website.

I experimented with the cura printer settings for dual mode.
This is my current start-code

;SV04 start
M140 S{material_bed_temperature};
M104 S{material_standby_temperature} T0;
M104 S{material_standby_temperature} T1;
M280 P0 S160;
G4 P100;
T0; select left extruder
M190 S{material_bed_temperature};
M109 S{material_print_temperature};
M420 S1;
G92 E0;
G1 X10.1 Y20 Z0.28 F5000.0;
G1 X10.1 Y200.0 Z0.28 F1500.0 E15;
G1 X10.4 Y200.0 Z0.28 F5000.0;
G1 X10.4 Y20 Z0.28 F1500.0 E30;
G92 E0 ;Reset Extruder
G1 Z2.0 F3000;

In my profile there was no extruder start and end code. I added this for the start code:

T0; (and T1 for the right extruder)
M109 S{material_print_temperature};

and this for the end code:

M104 S{material_standby_temperature};

The print is now starting correct (CURA 5.4.0) (only 2 layers are done)

The problem, the bug, it’s that Cura 5.4.5 start the gcode with these lines:

;Generated with Cura_SteamEngine 5.4.0
M82 ;absolute extrusion mode

And following it’s the machine code if you have defined it.

I spent my time checking 5.4.5 in a virtual machine and using the included SV04 profiles, and using the profiles provided by Sovol in the website, that I modified with a letter to have a difference. This profiles work fine in Cura 5.3.1. After slide a piece with PVA support in both machines and compared the Gcodes with 5.3.1 Gcode the error is this lines, that we can’t undelete. As you say, the solution is start the starting Gcode in the machine setup with a T0 instruction that come back everything to the “normal situation”.

Another bug appears with your Gcode. I tried before and Cura 5.4.5 doesn’t solve it. The lines

M104 S{material_standby_temperature} T0;
M104 S{material_standby_temperature} T1;

aren’t work fine. They heat both extruders but with the defined temp of extruder 0. Cura doesn’t have a parameter for different temperatures. The Gcode has the 2 different temperatures but the initial Gcode has the error.

My initial Gcode is like you with any change in purge and disabling the power off function

;SV04 start
M140 S{material_bed_temperature};
M104 S{material_print_temperature};

M190 S{material_bed_temperature};
M109 S{material_print_temperature};

M413 S0; disable Marlin power off resume

M280 P0 S160;
G4 P100;
G28; Auto home
M420 S1; auto bed level

G92 E0;
G1 X5 Y20 Z0.28 F5000.0;
G1 X5 Y300.0 Z0.28 F1500.0 E30;
G1 X4 Y300.0 Z0.28 F5000.0;
G1 X4 Y20 Z0.28 F1500.0 E60;
G1 E57; retraccion 3mm
G92 E0 ;Reset Extruder
G1 Z2.0 F3000;

And ending Gcode

;SV04 end
G91 ;Relative positioning
G1 E-0.8 F2700 ;Retract a bit
G1 Z0.2 F2400 ;Retract and raise Z
G1 X0 Y240 F3000 ;Wipe out
G1 Z10 ;Raise Z more

G90 ;Absolute positionning
G1 X0 Y{machine_depth} ;Present print
M106 S0 ;Turn-off fan
M104 S0 ;Turn-off hotend
M140 S0 ;Turn-off bed
M84 X Y E ;Disable all steppers but Z

I’m on 5.4.0, where did you find 5.4.5 ??

As for the temperatures for the extruders: it seems to work with the extruder start and stop code. Printer is using 2 different temperatures.
The print is still busy and looking good.

Does setting the power loss recovery off have an advantage??

The different temperatures work fine, but in your initial Gcode you wrote a command for both extruders. If you open the slided file you can see that in the initial gCode both extruders have the same temperature, the temperature of extruder 0.
Below, in the slided code, the temperatures are right.

Respect to turn off the resume function is in general know that the quality improve. To resume Marlin needs to write in your SD all the time to recover the printing state after a power failure. This cause delays and micro-pauses in the printing string that generate very small artefacts.

1 Like