Extreme Z-offset and bed leveling no longer running

Hello, I have a new SVO06 and have not bee very satisfied with the consistency of it at all. I am now dealing with failed prints and the print head printing off in the middle of nowhere, no matter what I set the Z-offset to. If I tune the z-offset mid print it end up being any where from -12 to -20 offset to even get the head close to the board. All of this occurred in same day in between a print change. I printed one print fine, then started the print again after it completed and now nothing prints…

The weird thing is I run a bed level process from beginning to end, then tune the Z-offset, which when I first got the printer and for a couple of weeks was set at -2.42, but now I have to set it -12.470 to pass the .2mm test. I then start a 4 square bed level print and then it prints in the air, and then in order to get it to print on the bed, I have to adjust the z-offset to anywhere from -17 to -22 to get it to stick…

I am pretty familiar with bed leveling, I have been printing for years with 3d printers of all kinds. Not saying I am an expert, but it is not basic user error here.

I have tried all of these things with ZERO improvement -

Re-leveled multiple times
Z-offset tuning
Power cycles
Different prints

Starting to feel like I got a hot pile of garbage in a cardboard box for Xmas…

1 Like


I had a similar problem. In my case I didn’t follow the proper sequence for the leveling.
I only did the auto home once but it needs to be done twice in a row. The first time it heats the bed and nozzle and only during the second run it comes close enough to the build plate to configure the z-offset.

Maybe this helps

Thanks Karl, I wish this were the case. But it is not. I really am struggling with this printer. I have had more issues with this printer than my original Ender 3 I got 6 years ago… You would think that the software/firmware would be a little more stable these days…

1 Like

From what I can tell by watching a bunch of videos and reading forums, it looks like the auto home and preprint home reset the print head to about 12mm higher than the Z axis setting. What I mean is every, and I mean EVERY time I attempt a print or re-level i have to decrease the z axis by about 12mm for each consective try to get the nozzle about .2mm from the bed.

Example -

I level the bed and save the settings, then i run the level bed process again, i need to adjust Z axis by -10 +/- . I do it again and I need to adjust again by -10mm, and now the Z offset is -22mm. If i did it again it would be at -32mm.

The same thing happens if i tune a print. Once stopped and then a new print started the I have to then ADD another 10mm of offset…

Hoping someone has some advice… I have emailed Sovol several times about issues with the printer when i received it and am still waiting for responses to those issues, along with this new on.

I’m not sure I’ll be of any help here but one more idea: have you tried to reset to defaults?
I guess you did and it didn’t help?

Yes I did do that as well.

Funny thing is after 6-8 hours of trying to get a successful print and all of them failing with the z-offset just printing in the air. I came out to the studio and ran a print and it printed just fine now… No changes from, it just magically started working… This is even more frustrating, now I don’t know when/if it will occur again.

:smiley: don’t forget to keep fingers crossed!! :smiley:

I feel your pain, my friend. I suspect your gantry is no longer aligned with your bed.

Please watch this 2 minutes video for the full bed-leveling procedure. My Tech Fun uses the same sequence as well here.

Is your bed probe working? Light going on and off when homing and approaching the bed? Almost sounds like your probe is stuck on.

1 Like

HI there, I set up my new SV06 today and I think I’m having the same problems you’re having. I can’t even get the benchy to print. The z-offset is doing exactly what you described and it’s driving me nuts. Did you ever find a solution?

Did you follow this: Extreme Z-offset and bed leveling no longer running - #8 by bassamanator

I wonder if your problem is linked with the fact that in the firmware there are two places to “Auto Home”, one in the “Prepare” menu and the other in the “Bed Leveling”. If I “Auto Home” from the “Prepare” menu the nozzle does stay pretty high over the bed only in the “Bed Leveling” I get to the heating and then to the “good” position.

Just a guess…

Did you find a solution to your problem (other than changing it to a paper weight), my printer has started the same thing…

I had this issue after attempting to align my Z-Axis using the instructions and gcode from here: Sovol SV06 X-Axis Alignment Using Bed Leveling Sensor (Replaces the "Auto Z-Align" Command). - YouTube (I don’t know if that had anything to do with it, but it was the last thing I did with my printer before I noticed the Z-axis zeroing was messed up).

I couldn’t find any setting to change to resolve it after trying everything I could think of. Eventually I resorted to nuking all my settings using the advanced configuration settings and resetting to defaults, and that seemed to fix it.

Not an awesome solution, and I would recommend writing down any settings you had to tweak beforehand (I forgot and had to dial in a bunch of things again), but it did seem to resolve the issue.

I’d love to figure out what happend tho.

I was having a problem of it not printing in the center, and it turned out the bed cable was tucked under the bed mechanism. The second i moved the cable out of the way it worked no problem. Also if you’re using prusa slicer just use the mk3s profile, it’s basically the exact same thing you just have to change the bed dimensions.