Cannot get TPU working :(

Hi all,

I have been successfully printing PLA and another PLA flexible filament without issues, but recently bought some TPU.

The bed of my printer is level, so there is definitely something wrong with the settings I am using for the new material.

It is listed as Siddament TPU - White TPU – SIDDAMENT

When I try and print the first layer it comes out like ok but the print eventually stops extruding the filament by the 5th layer.

I also notice when it comes out of the extruder there are gaps / as if it had moisture bubbles or something in it. I have had the filament in a dehydrator for the past 48 hours and there has been no difference in the result.

My settings are as follows: (based on generic flex prusaslicer)

Extruder 215 (I even tried higher up to 240)

Bed 0

Speed 20 even tried 10.

retraction - off

Any other settings I could look to change?

Thank you


I’ve printed TPU without any problems

My Settings are:
Hotend: 215
Bed: 60…it’s your choice I’ve always used a heated bed.
Speed: anywhere from 15 to 60…you have to play around.
Turn retraction on…this is your problem. it should be set just like PLA & others at .05

1 Like

Cheers, I tried that and still seem to be hitting problems.
The good news is now I can see where the issue is, I just don’t know how to fix.

What seems to happen is that the filament does not seem to load through all the time.
IE, IF I heat up the hotend to 125 and do a feed fo 5mm I can feel the side of the filament pinch my finger at the top so I know it is extruding.
Once the 5mm has gone through I do another 5mm and I no longer feel the filament feeding. It is like the hotend / heatbreak is ‘full’ and there is nowhere for the filament to go. (yet it isn’t clogging) I tried tightening the filament tension nut and still the same issue.
I’m not sure what to do next :frowning:

Heat to 185-195*, 125* is too low.
Also, feed it by unlocking the steppers & turning the extruder knob. Once you see it coming out, feed 10-20mm (5mm is not enough to check).


Sorry. 225 was the temp
I’ll give the knob turning steps a shot.

I’ve done a lot of printing in TPU (3DJake TPU A95 and Polymaker PolyFlex TPU95 - both print about the same) on my SV06 Plus now (12+ iPhone cases during the design iteration process, a couple of rubber ducks and numerous other objects) and I’m getting almost perfect results now.

Here are my settings:

Extruder: 215C
Bed: 60C
Flow: 104% (compensates for under extrusion caused by slight slippage on the extruder gear)
Print Speed: 40mm/s
Retraction Distance: 1.5mm
Retraction Speed: 20mm/s
Fan speed: 20% (note, I have a modified part cooling fan not the factory one)

From what you describe in a later post where it prints OK at first then stops extruding after a couple of layers my guess is the filament is slipping on the extruder gear when it warms up higher in the extruder through heat soak.

TPU is very soft and squishy especially when it heats up a bit - try turning the little black pin wheel with the spring on it beside the filament release lever two turns clockwise to apply more force to grip the filament between the extruder gears, then do another print. If it improves but doesn’t solve it try another couple of turns, but keep note of how many turns you’ve made in total so you can go back if necessary. If you set this too tight you’ll find you have trouble loading the filament.

I find it quite tricky to get TPU started in the extruder sometimes, I usually have to bend the bottom end of the filament to the left before inserting it then push it in and twist it around a bit while turning the blue extruder gear on the front until it “catches” and starts feeding properly. If you turn the wheel at the front and nothing comes out it’s not engaged properly.

A couple of other suggestions:

  1. If you’ve recently printed a high temperature filament like ASA (which I print at 260C) or ABS and you changed filament at only 215C or thereabouts this is not hot enough to flush through all the old higher temperature material and can cause a partial clog as there will still be some un-melted ASA in the hotend…

When you change filaments always purge the old filament out of the hotend at the same temperature you printed that filament at to ensure it fully melts, even if that is too hot for the new filament to print at.

The exception is TPU - don’t go directly from a high temperature filament like ASA to TPU as I recently tried to do - at 215C you can’t fully purge the ASA, but cranking TPU up to 260C during the purge process makes it go so soft and runny it actually stops extruding altogether and clogs.

To get around this I purged the ASA out using PLA at 260C, as PLA can still flow properly at 260C, and then purged the PLA out with TPU at 215C, as the old PLA will easily melt at 215C.

  1. Try unplugging the filament runout sensor and not threading the filament through it. While my Polymaker TPU seems to print OK through the runout sensor the 3DJake TPU is perhaps a bit softer and tends to get a little stuck due to the way the sensor pulls over at an acute angle - this can add extra drag to pulling the filament from the spool causing under extrusion - especially if the tensioning pinwheel is set too weak, or even cause the filament to start slipping completely on the extruder so it stops printing - bypassing the runout sensor is an easy thing to try to see if it helps.

As long as you have plenty of filament on the spool it’s safe to just bypass runout sensor, but you do have to unplug the plug on the side so the machine doesn’t think it has run out of filament. On a very full spool without the runout sensor constraining the filament movement you might occasionally get the filament jump over the edge of the spool, watch out for that, I’ve had it happen once.

1 Like

Excellent post

Mandrake, mentally noted

Good morning,
i also had these problems with TPU at the beginning.
The gamechanger was to put the filament in a filamentdryer and print directly out of the dryer.
Since then always had perfect results.
The filament should be in the dryer about 2 hours before you start printing.