Can someone please help me setup a camera on a S7, with octo print?

Hi, I have a Windows 10 computer and I am not very good at coding and was wondering 1. Where is the firmware update.
2. I have it connected to the internet through a browser and would like to ad octo print and a camera.

  1. I have been using Orca Slicer but I have Cura and Prusa which I am more familiar with.
    I have some config from some YT video from months ago and I was wondering if anyone had a better S7 config as he just changed some S6 features.

I should be able to use octobi with the S7 if I knew how to set it up.

I don’t know how to use Linux, if I should run it in a VM mode or use Git Bash but then I run into errors since I got most steps done but it won’t talk back through Github or asks for a password.
Not sure how to enter it in.

Any help with any of these. Thanks. The USB camera post goes to 404 page.

you can still find the article on the web archive

also, on the octoprint thing, it is possible however i would recommend having a think about why you want it. i also installed it on my SV07 when i got it but found that you loose so many features using the printer that way that it wasnt worth it and i ended up just using fluidd. if you still want to install it then you can use Kiauh, login via ssh using the instructions in the camera post and then run this command . ~/kiauh/ that should show you a console interface and use numbers to pick the options to install octoprint.

How many people know how to use Linux and Python, let alone know how to SSH into their Printer?

Another thing that if you are not from a tech background that you need to learn to get decent results.

Maybe I have a faulty machine?

It forgots where it is and will move off the heater plate and PEI cover so that the nozzle is off the board while the Led shroud and other parts jutter into the board until I, emergency stop it and by, hand manually raise the Z axis. Multiple times now.

i dont know what python has to do with anything since you shouldent need it to setup a camera. as for the SSH and linux part both are explained in the link.

for the machine issue, that sounds like it is not homing right or is in the wrong movement mode. have you made any changes to your config file for the printer?

Following those instructions bricked my printer. I suspect the page was taken down for a reason.

what step? im pretty sure there is nothing in there that should be able to brick the system

It was after I ran the apt update, I’ve seen a lot of posts from other people who have had the same problem. Enough people that someone posted a fix to GitHub, but that requires you to be able to Shell in and I can’t, it’s brick to the point where it doesn’t accept the connection even by the serial cable

those instructions never say to run apt update.

but i also cant at all understand why apt update would brick the system. all it does is download an updated list of packages, it dosnt actually install or upgrade any software. are you sure it wasnt apt upgrade?

The instructions tell you to run apt upgrade and point out that you may need to run at update first. When I ran apt upgrade, several packages didn’t install so I ran apt update and then apt upgrade again. That’s when it bricked.

can you post a link to the instructions you are following? the ones i linked in the post you replied to never once mention apt update or apt upgrade or any other apt commands

Octoprint doesn’t work with Sovol, or their other option. They specifically told me that it doesn’t work with Sovol’s

You are using a S6 Plus that you added Klipper to correct?
In Moonraker config it already has a spot for Octo Print even though they say to use the companionship app.

Should be as easy as entering your IP address in Moonraker and in the settings in your browser window. Also ask on Discord.

But I have yet to find a cam that works.
The original post used a UVC cam?_+. If I recall correctly.

They finally made a video sharing Christian Vick’s printer additions that are a major upgrade.

No point in having a fast printer that cannot print fast without errors.

Then again I might have received two lemons.
Some people have claimed that they have reliable SV07’s I can only speak to the two and multiple parts that broke on mine.

I was pissed with the one off Amazon a week ago was assembled just for the power switch to not work.
Some switch on the MCU had to be flipped but then as soon as I start setup, MCU error.
No amount of factory reset will work or adding a new Printer config file from a backup…

Don’t know electronics, don’t know Linux and have a DPN and VPN over my connection which shouldn’t change my WAN as it’s my own network.

The most pathetic act was when they sent me a piece of a broken PCB board with a 5 pin connection since the Klipper board enclosed needs a fan to stop the overheating and the accelerometer had melted into the connection.

What I was supposed to do with the broken piece of PCB is a mystery to me.
I have a messed up dominant hand, had surgery that didn’t help and micro tremors so soldering isn’t an option for me.
SV06 series seem to be more reliable, ust say stay away from SV07 series if you value your time and effort and sanity.

no, I have an SV07 but I damaged my screen (my fault, I was trying something stupid) so I am running it off a raspberry pi instead but using the same config as was on the screen.

for the rest of your post I honestly cant work out what’s going on so ill address things one at a time.

octoprint does work with sovol printers but it doesn’t work well with klipper so is not a good choice for the 07 or a converted 06. I suspect they tolled you that because they don’t know how or don’t want to help you with it (this is normal for low level support).

I don’t know what ip you are referring to or where you are entering it in moonraker and I don’t see where the browser settings come into it at all

any generic webcam should work, I have tried 3 (one cheap but normal one, one that was just a module I got off AliExpress and one usb endoscope) and they all work fine

honestly no idea what that relates too, sorry

for what its worth I have had 0 issues whatsoever with my SV07 (apart from the aforementioned screen issue that I caused).

from the sounds of it you are having more issues than just the camera, can I recommend you start a new thread and try and clearly lay out your issues ideally including a timeline of what has happened and what you have done to try and fix it. that will make it a lot easier for people to help.