Temperature sensors not reading correct

I recently disassembled my SV01 print head so that I could clean it. The heating element had a lot of build up on it. I think I might of had a tip that was not on tight and it was leaking plastic all around the heating element. There was significant amount of build up on it. I was able to remove it without to much trouble. It reassembled nicely without any problems that I could see (no left over parts).

When I turned on the printer everything seemed to be in working order so I started a print job, the job started really quickly, to quickly and that is when I noticed a problem. The nozzle temperature was reading 148C and the bed temperature was reading 89C. Since everything was a room temperature there was a problem. Given that I just cleaned the head I could see that I might of damaged the nozzle thermistor but I never touched the bed at all.

I would appreciate any help in figuring out how to fix the problem? or an explanation as to what happened. If I can’t figure out what the problem is I will have a rather expensive door stop.

1 Like

Hello Shaman
Please provide test video and pictures
1, confirm the nozzle shows 148 degrees and the hot bed shows 89 degrees after turning on the machine without heating? Then the actual temperature of the nozzle and the hot bed is room temperature?
2, it is recommended to re-plug the heating tube and thermistor line (nozzle and hot bed)
3, the situation remains unchanged, unplug the nozzle thermistor line and then turn on the machine to see if the temperature measurement of the hot bed is normal.
4, exchange the thermistor of the nozzle and the hot bed to see if the reading is normal.

If you have a multimeter case.
1, use a multimeter to measure the nozzle and hot bed thermistor resistance value is not about 100k ohms? (Test resistance value
Method: Multimeter gear rotated to 200KΩ gear, the positive and negative poles of the multimeter in the terminals of the thermistor line.)
Thank you
Best regards
Sovol Team

  1. Yes, everything is at room temperature and the display shows 148 and 89 (no heating).
  2. Don’t know how to get to the bed thermistor. See if I can figure it out.I removed the heating tube and thermistor on the nozzle and placed them back. No change.
  3. Nozzle thermistor removed and bed temperture did not change (still 89).
  4. What do you mean be exchange? swap them? Disable the cable wraps to remove the thermistors to swap them? I can do that but that.

I have a multimeter but where do do I make contact? The nozzle thermistor is coated with plastic. Can I scrap the plastic off? or do I need to find the end where it plugs into the main board?

I took a look at the bed thermistor, it will be difficult to get to it. The cables to the bed are glued to the bed with a black compound and the connections to the bed are covered with a thermal pad that appears to be also be glued onto the bed. Any suggestions on how to remove these without doing more damage?

Hello Shaman
1, exchange the thermistor of the nozzle and hot bed to see if the reading is normal, refer to the picture.
The customer has a multimeter.
2, use a multimeter to measure the nozzle and the thermal bed of the thermistor resistance is not about 100k ohms?
(Test resistance method: multimeter gear rotate to 200KΩ gear, the positive and negative poles of the multimeter in the terminals of the thermistor line. (Refer to the picture, nozzle thermistor and hot bed thermistor same method.)
Thank you
Best regards
Sovol Team

Ok, I think I’m missing something. What picture? Also how do I gain access to the bed thermistor without tearing the bed apart?

Sovol,
The cold (room) temperature reading is now 150 degrees for the nozzle (went a couple of degrees) and the hot bed is still reading 89.
Unplugging and replugging in made no difference (other than it went up 2 degrees).

Couple of questions:

  1. How do I exchange the nozzle and hot bed thermistors? I can easily access the nozzle thermistor but the hod bed thermistor is sealed under a thermal blanket on the bottom side of the bed and the bed cables are glued to the bed. How do I disassemble without damaging everything? How do I reassemble?
  2. How do you recommend measuring the thermistor value? there are no bare wires to attach the multimeter to?
  3. You mention a picture, what picture are you referring to?
    Shaman

Hello Shaman,
I’m sorry that the previous image was not sent to you. You can operate according to this image.


Thank you
Best regards
Sovol Team

Sovol,
Thanks for the pictures they were very useful.

  1. I swapped the sensors and the started the printer up and the nozzle temperature reading was 150 and the bed temperature was 89. No change in either reading.
  2. I used my multi meter and read each sensor resistance, one was 101K ohms the other one was as 98K ohms.

If I understand the above correctly then it appears to both are in good working order.

The only remaining thing I can think of is that the firmware is some how out of calibration.

I had a similar problem problem occur before with the X, Y and Z and extruder motors. I turned the machine on one day to do a print and from the beginning the print was terrible. I could not get it to work no matter what I tried. After several hours of trouble shooting I was able to determine that somehow between that previous print I did (about a week earlier), and this one, the calibration values, stored in flash, for X, Y, Z and the extruder, had been erased (no clue how). I was able to fix the problem by watching some youtube videos and figured out how to re-calibrate them. That solved the problem for me and the print finally worked. That part that frustrated me the most is I have no idea how the values were cleared in the first place.

Anyway, I am not sure if it is the same problem or not. I can’t get the printer to successfully print anything right now.

Hello Shaman.
Resistance value is within the normal range, may be the motherboard or firmware problems, please brush the firmware first, if still can not be solved, you need to contact our customer service staff, he will arrange to send you a replacement motherboard.
1, firmware: Marlin2.0.0.zip - Google Drive
Reference tutorial: How to Install Touch Screen on Sovol SV01& Sovol SV03 and Flash Firmware - YouTube (from 2 minutes 50 seconds).
Sovol official website: info@sovol3d.com
aliexpress:3020058294@qq.com
US Amazon:amazonus@sovol3d.com
Euro Amazon:sovol_3d@outlook.com
Ebay: sovol-uk@outlook.com
Thank you
Best regards
Sovol Team

I’ve never heard the term ‘brush’? Do you mean update the firmware? Currently running what it came with, namely version 1.1.6.1. I’ve not tried updating it because it has been working.