SV06+ 'Z=0.0' with any change in Z height

I’m loving the new 06+ and is has turned out a month’s worth of fine models. However, it now has an issue that I can’t grasp. Here is the situation:

When I auto-home (after manually setting and saving the nozzle at the correct height above the bed), the Z rises about 20mm, centers in the bed, rises as if to home Z, but returns to about the 20mm mark. If I check the axis movement screen, it shows this as the new ‘Z=0.0’. If I home again, the same happens, except now it’s about 40mm above true Z0. Again, the axis movement screen shows ‘Z=0.0’. If I run the bed leveling sequence, the extruder and bed heat as normal, the Z rises, goes to X0Y0, returns to mid-board, and stops. At any height change the axis movement screen shows ‘Z=0.0’. It even does that if I run the Z-alignment, except now the Z=0.0 is at the top of the gantry.

I’ve manually set the Z (with the printer off) at the correct height using a feeler gauge and saved the settings. I’ve also reflashed the board with a new, formatted 8Gb chip using the .bin file provided on Sovol’s website. I can’t find a loose connection, but acknowledge I might have missed some detail here or there.

What am I missing? I know others have had Z issues but can’t find THIS solution on any thread.

If I understand correctly, it just seems like you need to set the Z-Offset.
Go through the leveling process again using the guide that came with the printer.


Thanks for the reply. I’ve set the Z_Offset but this is a loss of the actual Z0. For example, if I could print without homing, it would print correctly. But after the initial auto-home sequence at the start of the print cycle, the printer nozzle moves from actual zero to about 20mm above that point. The problem is that once it has raised, the printer sems to think that the new height is zero and tries to print from that height. If I stop the print, run auto-home again, the process repeats except now the print head will be about 40cm too high. However, the printer (apparently) thinks the new height (~40mm off the bed) is zero. Each time, I go back to the axis movement screen and the settings read X0, Y0, Z0 (X and Y are correctly at their zero positions; z is not).

Note: if I raise or lower the z axis manually using the axis movement screen to scroll it up/down in the given increments - I usually use 10mm when changing a nozzle or whatever - the z position reading stays accurate. The glitch only happens when the movement is being controlled by the printer/gcode itself.


Did you happen to add a Z-Offset plugin (Cura) or something like it in whatever slicer your using…??
Did you change or add any new Start G-Codes…??
Other than the above, I’d say it’s still a leveling problem.

1 Like


No G-code changes. I’ve had an idea though. I think perhaps the proximity sensor is bad. I don’t know a lot about them but here is my observation: the LED doesn’t come on when I put a piece of metal (using a spatula) under the probe. I suspect that means it isn’t functioning but I don’t know any other way to determine. If the sensor is broken, am I right in assuming that the z can’t home or even know it’s position? I don’t have a spare or I’d switch out to test my hypothesis.

1 Like

Unplug & re-plug the sensor & then level the bed to see if the sensor lights up.
Also check to see if the sensor is set about 2mm past the nozzle.

No go on all. I don’t get a light even touching a metal spoon to the sensor.

I just tested mine. The light is on all the time, it goes off when I put a spoon close to the sensor.
So, if your light isn’t coming on at all…either the probe or the board is bad.

You need to email Sovol:

Thanks for the help. This is the first printer I’ve used with a proximity sensor. I’m used to manual or something like a BLTouch. I’ll reach to Sovol as you suggested. Thanks again.

What thing to try is reflash firmware using whats on the website and then clear the eeprom. Then do your auto z, set z offset and then run your mesh and save that.


I had reflashed already. This morning, I got a new unit from Sovol and bolted it on. The proximity sensor works and I was able to compare it to the unit I took off. The sensor on the removed unit had no LED on at any time. The new one has the LED on and it turns off when it senses the metal of the bed. So the whole homing/leveling problem came down to a faulty proximity sensor. I’ve asked Sovol about getting JUST the sensor and having the removed unit working (as a spare, backup, or whatever), but I’ve not had a reply to my email.

If they don’t reply, I’ll take that sensor off, print a mount for a BLTouch and change to that kind of sensor. I’ve read that some users are having trouble with the stock proximity sensor, so perhaps it’s something Sovol can tweak. Otherwise, I really like this printer. I have a CR-10 and Ender 3 Pro from Creality and two HyperCubes. But this Sovol is rapidly becoming my favorite … provided sensor/hotend/extruder issues don’t force me to change my mind.

1 Like

I am not sure what brand they use for the inductive probe, but I think its a cheap version.

1 Like