SV06 X-axis receiving "Driver ERROR please reset device" during zalignment

It won’t let me add a video or photo because I guess new users can’t use attachments? Kind of difficult to show an issue without uploading a video but I digress.Heres a link to the videos and photos on Facebook.

I got my printer on December 23rd, I put it in the house because we were going on a trip to see family for the holidays put it inside (super excited because it came almost 20 days earlier than what I was told),I returned this morning January 1st and put it together today.

After following the instructions I got to the part where you do the Z alignment and it moves up a little then grinds hard ( did not reach the top) and given a driver error. I reset and tried again still same.

So I:
reset the configuration to default settings

Reflashed the firmware

Set tensioner tighter and looser

Manually realigned z-axis thinking it was having issues on the x-axis because the z weren’t aligned.

Went into setting and had the stepper move each axis. z worked fine and x failed grinding trying to move 10mm

Unplugged x-axis stepper and ran zalignment again
Process worked fine. Plugged x stepper in again tried again failed again.

I own a JG maker artist d pro and after almost rebuilding it other than the board case and power supply, I bought this looking at review after review finding just the zrails might need to be manually adjusted out of the box and I was fine with that. But I’m having flash backs of the JG maker, seeing I have either a blown board or stepper motor, or both straight out of the box…

I purchased this machine because of ease of use compared to my other machines and plentiful reviews stating this is a good starting printer if not the best, so I’m not a beginner but I just wanted that ease. Has anyone dealt with this issue? I can’t seem to find anyone else experienceing the same issue.

Just wanna check something following.
Before refreshing the firmware, you must format the SD card. Only the firmware is stored in the card, and no other files are stored. It may be that the customer has not flashed the firmware.

Move each axis and E motor separately to see which one is moving and an alarm will pop up, unplug the cable on the nozzle, and then move each axis to see

Follow the operation steps: Configuration-Advanced-Advanced Setting-TMC Drivers, check if there is any problem with the drive current parameters of the motor, as shown in the figure; adjust the drive current appropriately to see if it can move normally, (adjust the adjustment parameters once value 50)


I am hitting the same error (through pronterface it appears to be the Z stepper driver) shortly after performing any stepper moves. Is there any further information around debugging the problem? Since it’s a new printer, I suspect this issue is a faulty driver.