SV04 will not home or lower gantry - Latest on long list of issues

Received the printer April 20th and still have not made a succesful print. I have resisted posting and tried to work these issues through support but i seem to be getting nowhere. I have pulled this thing apart so many times ive worn out the threads.
So far i have replaced
Control board x2
Thermistor x2
Hotend x1
Jumpboard x1
Extruder Gearset x1
Powerswitch x1
Firmware x10+
Diagnostics and troubleshooting almost daily.

Finally i was able to print an XYZ cube and it turned out not half bad considering. At the end of the print, the hot end slid down and contacted the waste bucket (like i said, threads are getting worn out). I raised the z axis to investigate, reinstalled hot end, went to home and the z axis never would come down. I tried to lower via touchscreen and it will go up but not down. The CR touch wll travel a few times and start blinking red. I pulled the CR touch off another machine and had the same issue. Reflashed the firmware, no change. Before going any further, i felt i needed to try something diffrent and post here.

I ve also checked continuity from the cr touch to the jumpboard, Jumpboard to control board and then control board straight through to the cr touch all seemed fine but i found it odd that black had two seperate pins (output of jumpboard) and red / white shared a pin. I compared it to the one i removed and it was the same, so has to be correct.

So far they have resisted a refund or even partial refund. I am not new to 3d printing either so not a newbie issue. I have countless hours ill never get back just to try and get one print.
any ideas?

A few thoughts:

  • Your SV04 has been dismantled & assambled several times - are you sure that everything is in correct place & that all contacts are still functional & without pinched wires / short circuits? If not - this documentation might help to check&compare.
  • Having a closer look to the documentation above it seems that yellow & blue wires of the CR-touch are swapped between board and sensor wiring.
  • Marlin firmware contains instructions to trigger a self test for the touch sensor. This should also work with CR-touch.
  • The waste buckets are fixed to the X-axis. The gap between nozzle and bucket can be changed using the bucket holding screws or simply by bending the buckets a bit.
  • Worn threads can be revived a little bit with a medium strength screw sealer like loctite threadlocker.