Sv04 extruder 2 bumping against extruder 1 at end of single mode printing

hi. I am having this:

Single Mode print - extruder 2.

At the end of the printing, when the print is finished, no more layers to go, Extruder 1 moves to the right, bumps the Extruder 2, and then Extruder 2 go to its end position and bumps against the structure.There is a huge noise too when Extruder 2 arrives at the parking position at the right side of the table. I made a video to show the issue and I am uploading it.

I wonder if this will break my printer in the long run.

Here is the final part of the gcode. If something is odd, or if there is a way to give a diffeent instruction to extruder number 2 so it will not crash against extruder number 1 thank you.


I believe that Extruder 1 should move AFTER extruder Number 2 at the end. Please can you correct it, send me a good setting for the end gcode of the machine? Because this just cant be right.

1 F600 Z2.5
G0 F7200 X48.6 Y107.2 Z2.5
G1 F600 Z2
G1 F1800 E959.7438
G1 F1200 X48.21 Y107.352 E959.7612
G1 F1800 E957.7612
M140 S0
;Single 02 end
G91 ;Relative positioning
G1 E-2 F2700 ;Retract a bit
G1 E-2 Z0.2 F2400 ;Retract and raise Z
G1 X0 Y240 F3000 ;Wipe out
G1 Z10 ;Raise Z more
G90 ;Absolute positionning
G1 X-62
G1 X362
G1 Y302 ;Present print
M106 S0 ;Turn-off fan
M104 S0 ;Turn-off hotend
M140 S0 ;Turn-off bed
M84 X Y E ;Disable all steppers but Z

M82 ;absolute extrusion mode
M104 S0
;End of Gcode
;SETTING_3 {“extruder_quality”: [“[general]\nversion = 4\nname = _TPU_SINGLE
;SETTING_3 printalot\ndefinition = SV04_Single_Mode_2\n\n[metadata]\ntype =
;SETTING_3 quality_changes\nsetting_version = 16\nposition = 0\nintent_catego
;SETTING_3 ry = default\nquality_type = draft\n\n[values]\nbottom_layers = 1
;SETTING_3 0\ncoasting_enable = False\nmaterial_final_print_temperature = 210
;SETTING_3 \nmaterial_print_temperature = 228\nretraction_amount = 2\nretracti
;SETTING_3 on_speed = 30\nspeed_infill = 20\nspeed_print = 40\nspeed_wall_0 =
;SETTING_3 20\ntop_layers = 0\nwall_line_count = 2\nwall_line_width_x = 0.4
;SETTING_3 \nz_seam_corner = z_seam_corner_none\nz_seam_position = front\n\n”
;SETTING_3 ], “global_quality”: “[general]\nversion = 4\nname = __TPU_SINGLE_p
;SETTING_3 rintalot\ndefinition = SV04_Single_Mode_2\n\n[metadata]\ntype = q
;SETTING_3 uality_changes\nsetting_version = 16\nquality_type = draft\n\n[va
;SETTING_3 lues]\nacceleration_enabled = False\njerk_enabled = False\nlayer_h
;SETTING_3 eight = 0.25\nlayer_height_0 = 0.25\nmaterial_bed_temperature = 60
;SETTING_3 \nretraction_combing = infill\n\n”}

Hi, i had the same problem, i just updated the firmware on the board an the touchdisplay, after that it worked fine.

1 Like

My firmware was updated too. What solved was correcting the original faulty gcode provided by sovol.

Firmware is not a fix. I just got my Sv04 set up and it had v1.1.0 preloaded. Currently have this issue using the single mode 01 AND dual mode in the Sovol Cura software. Extruder 2 trying to go to wrong home position at end of print.