Stops Mid print

I have yet to get a usable print from my Sovol SV06 Plus. Prints starts fine - good bed adhesion and great quality of print for a good number of layers and then it just stops. At this stage the screen is unresponsive and I have to restart to move the z axis away from print. I have tried the Sovol slicer and normal cura with different models but each starts of fine and then Stops. This problem is with all prints not just one or two. Can anyone help.

Well I finally found a solution to my problem and it may be useful to others.

The sv06 pro has a usb port located in an awkard position. I have had this before on other printers and my solution was to buy a USB extention from Amazon to allow a usb slot at the front. This has worked fine on other printers.

I now find that this was the cause of my problems on the SV06 Plus. Plugging the USB directly in without the extension has resolved all my problems and I am getting superb prints. Pity it took me so much time to find the cause.